Support » Plugin: WP Photo Album Plus » users can’t upload images

  • Resolved pinballnate

    (@pinballnate)


    Hi,
    I deactivated every plugin except wppa and still only an admin user could fe upload. It was working at the first version 8 you put out but at some point it stopped working – I don’t know when because i wasn’t testing users for a few days. When I roll back to previous versions it still does not work. I checked all of the settings and I don’t think I changed anything since it was working except updating to the latest versions.
    Any ideas on what I could check that would create this problem? I am getting ready to go live with my website and this is bad timing.
    Thanks for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter pinballnate

    (@pinballnate)

    Last resort, is there a way to reset it and start over? I guess just delete the plugin then download it again? Don’t really want to lose my albums and settings though.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I will make a fix available in a few hours.

    You can always de-activate and delete and re-install a different version without loosing any albums or photos.

    You can install any non-standard version by uploading the zip on the Plugins -> New -> Upload plugin page. You will be informed that the plugin is already installed and asked if you want to replace it by the upload. Answer yes to that question and it will be installed.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Download https://downloads.wordpress.org/plugin/wp-photo-album-plus.8.0.03.001.zip
    Install as Plugins -> Add New -> Upload Plugin, and click the ‘Replace current with upload’ button.

    Changelog of 8.0.03.001 so far:

    = 8.0.03 =

    * Extended alternate ajax methods and fixed certain links.
    If frontend ajax links do not work, you can select different ajax methods on Advanced settings -> System -> I Item 5: Ajax method. (‘Normal’ is default).
    ‘Classic’ is like pre ver 8 method ‘Ajax non admin’ ticked, ‘Backend’ method is like pre ver 8 ‘Ajax non admin’ unticked (uses admin-ajax).

    If frontend upload does not work (give errors) set Advanced settings -> Users -> I Item 5.1: Upload Ajax method to ‘extern’ (like ‘classic’) or to ‘backend’ (uses admin-ajax). (‘normal’ is default).

    Note on upload. If you want users to upload to sites that have a site password, i.e. where users do not need to login with their name, treat them as non logged in.
    To allow uploads in this case: tick the box in Advanced settings -> Users -> I Item 32: Upload logout, and make sure the owners of the albums allowed to upload to are set to —public—.
    If you do not use the widget or the upload shortcode but let them upload using the album cover link, make sure empty albums are not skipped, to allow for the first upload.
    See Basic settings -> Albums -> II Item 7: Skip empty albums.

    Thread Starter pinballnate

    (@pinballnate)

    Still not working for me. I don’t know if it makes a difference or not, but I am using the shortcode [wppa type=”upload” album=”9″]

    Thread Starter pinballnate

    (@pinballnate)

    Hi Jacob,

    I figured my problem out. I think all of my albums used to be children of an album that was owned by public but I maybe deleted that album which made all of my albums children of none and owned by me, the administrator so only I could upload to the albums.
    That’s what I think happened.
    Thanks for trying to troubleshoot, I hope I didn’t eat too much of your time for nothing.
    Nathan

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘users can’t upload images’ is closed to new replies.