Support » Plugin: Sabre » User's can't register. Database error?

  • I’ve been pulling my hair all day & can’t figure out why this isn’t working. I’ve installed the SABRE plugin, and it’s been blocking all attempts at registration. I look at the database & the wp_sabre_table doesn’t exist. I see a few other people get this error, and create the database table manually. Still no dice.

    So I export one of the SQL queries & try it to enter it manually in mysql. That works fine.

    INSERT INTO wp_sabre_table SET user_IP = ‘’, first_mod = ‘2012-12-27 21:21:42’, last_mod = ‘2012-12-27 21:21:42’, letter = ‘R’

    This is where things get weirder. I add this

    $wpdb->show_errors = TRUE;
    $wpdb->suppress_errors = FALSE;

    into the code about line 150 (before that sql query gets executed)

    And I get this:

    WordPress database error: [Table ‘xyz_abc.wp_sabre_table’ doesn’t exist]

    No here is the interesting thing: My database name isn’t xyz_abc! It’s close to the database name, but not what’s in my config.php (let’s say that’s def).

    I’m totally stumped here. Not sure what to do next…

    Any help would be appreciated.

    WP 3.5
    SABRE 1.2.2

Viewing 1 replies (of 1 total)
  • I took the liberty of updating a few things in the plugin including this error because I really wanted to use it and the developer seems to have disappeared. If he ever comes back, I’ll be happy to remove my link. Deactivate the current version of the plugin and delete it. Then upload this zip file to install the updated version… and you should be back online.

    I’ve updated it a couple times for various things, so I just tacked another .2 onto the end of the version number.

    I’ve fixed the MySQL table creation error by removing the deprecated TYPE option.

    I’ve also fixed the DNS blacklist issues. The queries worked, but they would return false positives. I replaced with the two correct servers: and

    I also updated the gethostbyname logic to prevent false positives. It will only show the banned ip error if one of the proper DNS blacklist servers recognizes the IP address.

    I don’t have much time to maintain a plugin, but I did fix what wasn’t working for me — and what most people are complaining about on here. I cannot guarantee that I’ll be able to fix any other issues as I seldom have time to visit the forums.

Viewing 1 replies (of 1 total)
  • The topic ‘User's can't register. Database error?’ is closed to new replies.