Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Users cant press accept all cookies

  • Resolved traderex

    (@traderex)


    as the title says its currently bugged for me and I dont know how to fix it

    can you take a look please?

    thanks

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor jarnovos

    (@jarnovos)

    Hi @traderex,
    Could you try Disabling the Elementor integration? (WP Dashboard > Complianz > Integrations > Plugins)

    Kind regards,
    Jarno

    Thread Starter traderex

    (@traderex)

    Hi thanks for the very swift reply

    sadly this did not fix it

    any other idea?

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @traderex,
    I’m not getting a console error when I click the “Accept All” button, this points me in the direction of another script or plugin possibly interfering with the Cookie Banner.

    First, could you try to disable Minification and Caching plugins? That will help in ruling out caching errors as a possibility.

    Disabling plugins one-by-one will also help with identifying the cause of this issue.

    Let me know if you have any updates.
    Kind regards,
    Jarno

    Thread Starter traderex

    (@traderex)

    Hi again

    I deactived lscache, forget spam comments, asset cleanup and imghaste which are the only plugins which are about minification or caching

    sadly not fixed 🙁

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    As this works without issues on default setups, it has to be one of your plugins, or your theme.

    Can you try to deactivate all plugins except Complianz, then try again? If that doesn’t help, also switch your theme to a default WordPress theme.

    If the button starts working again, activate them one by one until it stops working. You’ll then know which plugin is causing the conflict. I can then install that plugin to investigate the problem.

    Thread Starter traderex

    (@traderex)

    hi thanks for your reply

    I just created a staging site to test it and strangely it works there even though i did not change anything

    how could that be?

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    That is strange! There has to be a difference somewhere. Is this an exact copy, with a copy of the database?

    Thread Starter traderex

    (@traderex)

    yeah completely the same, i chose the staging as I dont want to disable the plugins and destroy the layout of the live website

    i could send you a login link if you want to take a look and if you provide me with ur email

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    I’m sorry, if I do that I get the WordPress moderators after me.

    What you could do is:
    – re-save all settings you can find, in all plugins
    – then clear the cache and minification again.

    Maybe try deactivating some of the less important plugins.

    Thread Starter traderex

    (@traderex)

    Hi

    i did it on the live site and now i know why it did work on the staging and not the live

    its the imghaste plugin which is currently buggy with complianz

    maybe you can check out any compatbility issues, as I had to disable imghaste now..
    that would be great 🙂

    thank you!

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @traderex,

    I tried on https://s-q6g93nyrg4sdl.eu1.wpsandbox.org/, and have the IMGHaste plugin and Complianz enabled, with the standard theme without issues.

    Could you try one last thing? Disabling all javascript related optimisation when asset clean up is enabled, and clearing cache afterward.

    regards Aert

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @traderex,
    Has the suggestion from @aahulsebos helped with fixing the IMGhaste issue?

    I’m marking this as resolved for now, please feel free to reach out if we can assist any further.

    Kind regards,
    Jarno

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Users cant press accept all cookies’ is closed to new replies.