Support » Plugin: PowerPress Podcasting plugin by Blubrry » Users can no longer log into protected content

  • Hey Angelo,

    I am so sorry to bug you again but Paul from MemberPress just referred me back to you.

    The protected content feature with MemberPress had been working flawlessly and now it now longer plays nice. Users cannot login either to their account online (it appears they do but really they didn’t because the protected content is not visible to them) or through iTunes where it continually pops up asking for the password again and again.

    Paul seems to think it’s a cookie issue not being stored. I was playing around with W3TC but I never checked the option to “not store static cookie files in the header.” Regardless, I am now back to SuperCacher built and maintained by my host Siteground which is fast but minimal and had never been an issue in the past + Cloudfront CDN.

    I tried turning it off to see if it would resolve the issue but it does not. I tried restoring my site to an earlier time three separate times but that doesn’t work.

    I’m at a loss as what to do and am getting inundated with emails about this problem. Can you help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I realize you don’t owe me anything but I’m desperate. I took the nuclear option and restored my site from 30 days back and then checked the protected feed and it worked in iTunes.

    I made no changes to plugins other than updates and changed the CDN out in my caching plugin because the one I had there was obsolete and my site wasn’t rendering correctly.

    I made some minor cosmetic CSS changes to the site and now all of a sudden it no longer works.

    Subscribers CAN log into the site and download or stream but they cannot via iTunes and I’m at a loss as to why. Nothing’s changed.

    Maybe I need to add something to the .htaccess file or wpconfig.php file but I just don’t know.

    Plugin Support Shawn Thorpe

    (@shawnogordo)

    I have forwarded your requests to Angelo. He’s involved in several projects today with different staff members and will respond here as soon as he can.

    Thanks Shawn. Just to go over the troubleshooting steps I’ve taken:

    Turned each plugin off one by one to see if that resolved the issue; it did not.

    Used the issue resolver one by one in the settings after clearing my cache each time for each step; it did not.

    Tried using the TwentyTwelve theme from WordPress; it did not.

    Took the nuclear option and reverted my site back 30 days prior to when I knew it was working; it worked briefly but then stopped.

    After reverting my site back; I went and did all of the above steps again but none worked.

    One other thing. Subscribers CAN now login to the site and download; just not through iTunes, which is a bit odd.

    I’m thinking there is something missing in my .htaccess file or wpconfig.php file but can’t say for certain.

    At this point; I’m out of options and have several angry subscribers. Anyone that’s ever worked in customer service will tell you how vicious people can be no matter how justified their ire.

    If there was a way to reset the plugin that would be awesome. I did try uninstalling it and then deleting all references to it in my file manager but I must have missed something because everything was still in place after clearing my cache and browser and then reinstalling it. Probably the database but I wasn’t comfortable touching that.

    I found this in the wpconfig.php file just wanted to ensure this is correct:

    define(‘POWERPRESS_CONTENT_ACTION_PRIORITY’, 99999);

    define(‘POWERPRESS_PREMIUM_GROUPS_PLUGIN’, true);

    Plugin Author Angelo Mandato

    (@amandato)

    It may be correct. The POWERPRESS_CONTENT_ACTION_PRIORITY tells pwoerpress to wait for other plugins to add to the content of the page before PowerPRess adds the player, which may be necessary if you have a plugin adding stuff into the pages that breaks the Podcasting player options.

    The POWERPRESS_PREMIUM_GROUPS_PLUGIN define is necessary if you are using the “Groups” plugin. The groups plugin is commonly paired with WooCommerce plugins.

    As far as as cookie issue, podcast applications cannot see or use cookies, so if MemberPress is using them, that is the problem.

    Hey Angelo,

    Great to hear from you!

    I restored the site to the 1st and it was working. I slowly made changes; removed plugins; added others; added my custom CSS and had to re-post 5 posts that had come out since then.

    In-between all of this; I’d clear my cache and check the feed and it worked the whole time.

    The very last thing I did was change the wording on the protected content box because what I had there was confusing to folks. Bingo! The minute I changed it out, the feed broke and you couldn’t login. You can log into the site and stream and download; just not the feed itself, which means it does not work in iTunes. You can’t even get it back by replacing it with what was there before.

    I thought maybe my closing tags were wrong but they weren’t. This took all day because I hit my shared hosting CPU limit with Siteground logging in and out and making changes so they slow you to a crawl.

    I just sent them a support ticket to restore my site later in the month since me trying to do it will take an act of Congress. My site will be open and likely have exposed links all night but I just don’t care anymore.

    I’ll look into the cookie issue tomorrow but to be honest; I don’t have it in me anymore and will likely shut the site down.

    Thanks for providing feedback.

    Plugin Author Angelo Mandato

    (@amandato)

    Hello @kjam,

    I am just following up what you ended up doing with the premium podcasting?

    Thanks,
    Angelo

    Hey Angelo,

    I think it was a corrupt database that only seemed to affect PowerPress. I deleted the plugin and removed all references from my database. Then went back and reinstalled the plugin and several changes were immediately noticeable when I went back to set it up (keywords and copyright fields had been deprecated among many others).

    Apparently, when the big update was applied back in July it never took hold on my site. That had not been an issue with any other plugin. Anyway, I was moving around using my workaround all that time until it no longer worked for folks.

    I’ve since dropped Memberpress and reverted back to a donations based site, which will better suite my purposes in the long run. Though, a likely significant loss in revenue to run the site.

    Anyway, I just finished manually re-adding all of the podcasts about an hour ago and the site is now open again.

    Thanks for checking in!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Users can no longer log into protected content’ is closed to new replies.