Support » Installing WordPress » Username/Password incorrect for admin

  • I’ve set up a new site, installed 2.92 and changed the password on the admin user page. But when I try to install a new theme, new plugin, enter the username:


    in the Connection Information window I keep receiving the following message:

    Username/Password incorrect for admin

    I’ve searched the support forum, and cannot find a solution. I’m sorry if this has been resolved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    You need to enter your ftp host, ftp username and ftp password. Contact your host if you do not have this info already.

    thanks so much. yes, I can be an idiot.

    I have the same problem. Is the ftp username and password different than what I use to access the blog using my admin username and password?

    yes its not at all related (unless you set them the same)

    your ftp username and password has nothing to do with WP, it’s something you set through your host or they set for you

    I’m getting the exact same problem, and was going to open a new topic in the support forum, but I might as well piggy back here.

    We’ve just installed wp on our server. I log into the admin panel and try to install a new theme. I’m prompted for ftp credentials:

    FTP username:
    FTP password:
    Connection Type:

    And nothing I do works. I regularly FTP to this server, so I know that FTP works.

    For the hostname, I’ve tried [hostname], [], “localhost”, and the IP address. I’ve tried both connection types.

    I’ve also contacted my hosting provider and they comfirmed that there is no setting, that they are aware of, on their servers that would prevent WP from connecting via FTP.

    I’m at a dead end. Any advice for next steps?

    Thank you.

    I encountered this problem. It looks like a bug and there’s a workaround.

    My wordpress install is 3.0.4 on a linux server.

    I ran the php-based theme installer with FTP account details. It looks like the installer created a temporary folder “upgrade” in the wp-content directory.

    I ran the installer again with FTP account details for a different FTP account. It looks like the permissions of the leftover “upgrade” directory in the wp-content directory blocked the install process.

    The error message for the problem was “username/password incorrect for …” which was misleading.

    I changed the permissions of the “upgrade” directory to 777 – and this has unblocked the install process.

    WordPress will ask for FTP login in situations where WP doesn’t have enough folder permissions. There for it’ll be offering different file management ways of getting the plugin installed.

    If the WP isn’t able to access FTP server and encounters problems even when login info is correct you can also manually download the plugin and copy it’s files to the plugin folder in “wp-content” (and extract if necessary)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Username/Password incorrect for admin’ is closed to new replies.