Support » Fixing WordPress » Username not working

Viewing 15 replies - 1 through 15 (of 25 total)
  • How did you try to copy the site?

    Can you access the database in phpmyadmin?
    I’d be interested to see what is in the wp_options table; specifically for options ‘home’ and ‘siteurl’.

    Jibbius, thanks so much for responding. I’m afraid I only know enough to get myself into trouble (q.e.d.) but not how to do things like access phpmyadmin. I wouldn’t know where to find it, and anyway it seems I wouldn’t be able to login to it, since my username doesn’t work.

    I copied the site using the export function on the dashboard on storysmithy.com, which produced an xml file which I then imported into thebookofyourlife.net. Then I applied the same style (OceansEleven) and edited the links in each page so they referred to thebookofyourlife.net instead of storysmithy.com. I checked every page to make sure it worked.

    After that, I went to try to delete storysmithy.com. I couldn’t see an easy way to do it, but I noticed that I had earlier (before the new domain was fully set up) changed the options you mention — ‘home’ and ‘siteurl’ in storysmithy.com from that (www.storysmithy.com) to http://www.thebookofyourlife.net. Thinking that if I deleted the Story Smithy blog with those options left like that, I might delete the new blog (which I had set to the same home and URL — http://www.thebookofyourlife.net), I changed the options back to http://www.storysmithy.com, and that’s when I was uncermoniously dumped back at a login screen and have been unable to login ever since.

    The fortunate thing is that I have the xml file, so all is not lost, though I’m not sure how to rebuild especially if I can’t delete the existing blogs. If I could only get my username to work again and if the old storysmithy.com blog could be deleted, I think I could manage. Is there anything I can do in Dreamhost that would help, do you suppose?

    –David

    Hi David.
    If you have ftp access, add this to the top of the functions.php file in your theme directory ( on a new line immediately after <?php

    update_option('home', 'http://www.storysmithy.com');
    update_option('siteurl', 'http://www.storysmithy.com');

    Confirm the old site works again.
    You can then delete those lines, page only needs to be once with them there.

    As long as wp-config.php has a different database name, then WordPress will not “delete” the contents of both sites (when you try to delete one). I would wait till site 2 is perfect before deleting anything.

    Does the above make sense, or am I losing you at FTP?

    (just trying to gauge the level of information you need)

    I’m not sure if I did this correctly, but I entered http://ftp.storymithy.com into the address bar and to my surprise I got a login prompt. However, it would not accept the username and password I set up for the blog (I think it’s the username itself that is not being accepted. It’s not a password issue.) I also just discovered I can ftp in from Dreamhost “Manage Domains” page, but same end result (“Alert: 530 Login incorrect.”)

    With a broken username, I seem to be in pretty bad shape. I’ve been looking for a way to contact WP directly to see if they could help, but there seems to be no way to reach them unless (hopefully!) they happen to review these forum posts.

    –David

    BTW I did not put http before the ftp — I guess some robot put it in my forum post! 🙂

    Hmmm… You’ll need some ftp details to fix your problem. They are probably the same as your dream host login credentials.

    To edit files, you will need to use an ftp client (software tool) like filezilla.

    You’re starting to venture into a rather technical area. You might be able to save yourself a lot of trouble by enlisting some help from tweaky.com

    Dreamhost may also provide support?

    If you’re keen to do this yourself, have a look at this (to get your head around FTP) :
    http://blog-well.com/2008/08/10/beginners-guide-to-ftp-for-wordpress/

    The next step is understanding the database side of WordPress: http://wordpress.shadowlantern.com/how-change-wordpress-url-phpmyadmin/

    Good luck

    Wonder of wonders, I finally figured out how to WebFTP in with AjaXplorer (I had to connect to the Dreamhost server named Regulus and not to storysmithy.com), and I figured out how to edit phpmyadmin (I had to create a new user and PW on Dreamhost).

    In AjaXplorer, I changed the TwentyEleven theme file so that the very top of the file now reads:

    <?php
    update_option(‘home’, ‘http://www.storysmithy.com’);
    update_option(‘siteurl’, ‘http://www.storysmithy.com’);
    /**
    * Twenty Eleven functions and definitions
    …etc.

    I saved the file, but it has made no difference — I still can’t log in to either site via wp-login.

    Now I am in PHPmyadmin looking at table wp_qaydpc_options, which has rows for siteurl (“http://www.storysmithy.com”) and blogname (“The Book of Your Life”). Will changing either of these solve the problem? The Shadowlantern link you sent is all about changing the URL, but what would I change it to?

    Forgive me for being dense, and for taking up so much of your time and patience. I am wondering where you are and what time it is there — I am in Hawaii and it’s only just turned midnight, but if you’re in mainland USA it’s between 2 and 5 am!

    –David

    David

    Ah… actually the theme file change has made a difference. WHen I just go to http://www.storysmithy.com (without trying to login), I get:

    “The page isn’t redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    Am I getting closer?

    Melbourne Australia. 9pm
    Wow – That’s progress.
    Gimme a few minutes to type a response.

    Actually; it looks like your site is doing some circular redirection.

    http://www.storysmithy.com/
    Redirects to
    http://storysmithy.com/
    And then it heads back to
    http://www.storysmithy.com/

    Can you try changing the options to that instead?

    I think I can do that in Dreamhost. Will try.

    Melbourne! A great city, I have read.

    I’d be tempted to change it via either:
    – PHPmyadmin
    OR

    update_option('home', 'http://storysmithy.com');
    update_option('siteurl', 'http://storysmithy.com');

    Don’t change any other settings (domains…etc) in Dreamhost. I’m being explicit here, because there are “lots of things” in Dreamhost – just making sure we aren’t introducing more variables.

    The database became broken when the settings were changed in the wordpress dashboard. You want to fix the database, not change anything else.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Username not working’ is closed to new replies.