Support » Networking WordPress » Username changed plus can't access to network area

  • Resolved iLife


    Guys, I have learned a lot from this forum. But, this is my first post, actually regarding a problem. I have searched a lot but couldn’t get proper solution.
    Well, i have a wordpress installed network of blogs ( 5 blogs ) and quit a lot of plugins. Up to yesterday, everything was going perfectly. But, when i tried to login today with the same username ( edited ), i got authentication error. So, i checked and found that my edited username has magically transformed to “admin” which is wordpress default username. So, i changed the pass and entered using “admin”. I opened my profile to edit and as by default i was not able to edit the username. So, i tried to enter the network area but a message “You do not have sufficient permissions to access this page” is displayed and there i knew, i was degraded from super-admin to only administrator. At that point, i thought if my site was hacked or not. But while checking thoroughly, all the contents and plugins are same.
    After that, i disabled all the plugins from Cpanel, thinking if there might be some plugins conflict but still not able to solve this. Either i only have access to primary site and able to publish new posts etc but if i am not able to access network, its not possible to update, add or delete plugins, wordpress itself and other sites under the network. So, what should i have to do to solve this issue? Hoping for quick and effective reply from geeks here..
    Thankx in advance!!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • But, when i tried to login today with the same username ( edited ), i got authentication error.

    How did you edit your user name? This is the real crux of the whole matter, and if you went in to the DB to change it, that’s the problem. You CAN’T just do that.


    That mentions the right way, and WHY you can’t just change it.

    I have not manually changed it. I exactly forget by which plugin i have changed it for security purpose. And yes, it was ok till yesterday. But, still now, when i enter to “EDIT PROFILE” option, the same username instead of “admin” is shown. So, i can’t figure out whats happening. When i look on phpmyadmin even, username_sitemeta shows, site_admins as a:1:{i:0;s:5:”myusername”;}

    —- While in the process of replying, i have solved this issue. I have checked myusername_users in phpMyadmin, there i saw user_login has been changed from my username to admin, so i edited and changed back to the same old one, and magically it worked. Anyway thankx for the reply—-

    Debolded. Ow.

    Yeah, the REASON that happened is becuase in Multisite, the length of your user name is stored as a part of data serialization. So if you changed from, say, ilife to admin, you would have been fine. They’re the same length. But if you changed from jimisrealcool to admin, it would break.

    Now. The question remains which plugin did that… If you find out, please let us know so we can warn folks 🙂

    Oh. YEs this problem is solved but, still i aint able to find out which plugin had a part in playing this game. If i find out, i will definitely push here…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Username changed plus can't access to network area’ is closed to new replies.