Support » Plugin: EthPress - Web3 Login » Username already exists when user wants to login again

  • Resolved Ma Yannick

    (@diegocarven)


    Hi there,

    Amazing work you did there with this awesome plugin, congrats 🙂

    I have an issue, when a user logs off and then logs in again this message appears:

    Username already exists.

    I’ve seen in some precedent support tickets that it may be related to the DB, could you please tell me the way i could fix this ?

    I am not very experienced in dev so i’d appreciate if you could tell me step by step the way to fix it.

    Much appreciated.

    Diego

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author lynn999

    (@lynn999)

    My guess is that it would be a permissions issue. Maybe try disabling other plugins and disabling+enabling ethpress (so it tries to recreate the table).

    Then you could try some database plugin to see if the ethpress table exists or not.

    Thread Starter Ma Yannick

    (@diegocarven)

    Thanks for your answer.
    I’ve deactivated the plugins a reactivated ethpress but it still did not solve the issue.

    Could you please help me tu add the ethpress table manually in my DB?

    Thank you in advance

    Plugin Author lynn999

    (@lynn999)

    Sorry, that’s a bit too time intensive for me.

    Did you check that the database is actually the issue? Try a plugin to list database tables, then see if one of the names has ethpress in it.

    I have the same problem, could this be related to a WordPress multisite installation?

    Just to add some more info, I’ve been doing some research and seems to be unrelated to the multisite setup. I don’t see in the WP database any entry related to ethpress, maybe the bug comes from that.

    Plugin Author lynn999

    (@lynn999)

    Can you try the ethpress widget, and link your address to an existing regular wordpress account with it, and then try logging in with ethpress?

    If that doesn’t work, then yea it’s almost surely the database table missing. I would assume it’s some permissions thing, but that’s just a guess.

    Quite difficult for me to help out with that, so if you find solutions then please do post them here.

    Plugin Author lynn999

    (@lynn999)

    Hey, this might be fixed in 1.2.1, please try it out.

    1. Disable the plugin
    2. Delete the existing 0x… account
    3. Enable the plugin again

    • This reply was modified 1 month, 2 weeks ago by lynn999. Reason: Added steps

    Thank you, this time it works perfectly!

    Plugin Author ethereumicoio

    (@ethereumicoio)

    Glad it helped!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.