WordPress.org

Forums

SendPress Newsletters
user sync (23 posts)

  1. WooUser
    Member
    Posted 1 year ago #

    hi, having a problem with syncing lists...

    When i do a sync, it says the following, but only 14 users actually wind up on the list and the other 6 are missing.

    "Synced 20 users.

    All users not in role dealer where removed from this list.

    Your list is now up to date"

    http://wordpress.org/plugins/sendpress/

  2. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    Could you confirm that all 20 users have an email address? The only reason we can think of that it would not synchronize all of the users is that they don't actually have an email address to synchronize.

  3. WooUser
    Member
    Posted 1 year ago #

    yes they do..

    i thought maybe it had something to do with users having multiple user roles (capabilities) but it seems to be inconsistent in which names it pulls and which names it doesn't to me.

  4. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    I'll talk to the developers about this. Not sure what it could be, but that's helpful. Could you perhaps post a screenshot of the list settings page?

    Please click the following link for instructions on what info to provide support. Remove URL from output though.

    http://sendpress.com/support/knowledgebase/what-information-should-i-provide-in-a-support-ticket/

  5. WooUser
    Member
    Posted 1 year ago #

    i'm not sure where to get that info to provide to you that is mentioned on the link you sent...

    also, for the screen shot, i can do it but there is really no relevent information on the settings screen for a list.. just list name and radio buttons of the user roles... i don't think this will help you much.

  6. WooUser
    Member
    Posted 1 year ago #

    SendPress: Email Marketing and Newsletters by SendPress version 0.9.6.4,

    WC Version: 2.0.20
    WC Database Version: 2.0.20
    WP Version: WP 3.7.1
    Web Server Info: Apache
    PHP Version: 5.2.17
    MySQL Version: 5.5.34-log
    WP Memory Limit: 40 MB
    WP Debug Mode: No
    WP Max Upload Size: 10 MB
    PHP Post Max Size: 10 MB
    PHP Time Limit: 30

  7. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    A screenshot would probably help still as would all the support output. Support info is on the sendpress help tab.

    Dropbox or droplr are pretty good for sharing those.

    Do you have access to apache error logs? Sometimes those can help too.

  8. WooUser
    Member
    Posted 1 year ago #

    WordPress Version: 3.7.1
    SendPress Version: 0.9.6.4
    PHP Version: 5.2.17
    PHP Memory Limit: 256 MByte
    PHP Memory Used: 71.84 MByte
    MySQL Version: 5.5.34

    Database Tables:
    aig_sendpress_subscribers_event OK
    aig_sendpress_report_url OK
    aig_sendpress_subscribers_status OK
    aig_sendpress_subscribers OK
    aig_sendpress_list_subscribers OK
    aig_sendpress_queue OK

    Ports:
    Port 25: blocked
    Port 465: blocked
    Port 587: blocked

    Support info:

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No

    SITE_URL:
    HOME_URL:

    SP Version: 0.9.6.4
    WordPress Version: 3.7.1

    Platform: Apple
    Browser Name: Firefox
    Browser Version: 25.0
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10.8; rv:25.0) Gecko/2010
    0101 Firefox/25.0

    Database Tables:
    aig_sendpress_subscribers_event OK
    aig_sendpress_report_url OK
    aig_sendpress_subscribers_status OK
    aig_sendpress_subscribers OK
    aig_sendpress_list_subscribers OK
    aig_sendpress_queue OK

    Sending Method: website

    PHP Version: 5.2.17
    MySQL Version: 5.5.34-log
    Web Server Info: Apache

    PHP Memory Limit: 256M
    PHP Post Max Size: 10M

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 4 Status: Acceptable

    Show On Front: posts
    Page On Front: #0
    Page For Posts: #0

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: Off

    UPLOAD_MAX_FILESIZE: 10MB
    POST_MAX_SIZE: 10MB
    WordPress Memory Limit: 40MB
    WP_DEBUG: Off
    DISPLAY ERRORS: N/A
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    Akismet: 2.5.9
    All In One SEO Pack: 2.1
    BackWPup: 3.0.13
    Better WP Security: 3.6
    Connections: 0.7.9.3
    Contact Form 7: 3.5.4
    IgniteWoo Updater: 1.0.2
    Nav Menu Roles: 1.4
    PC Hide Pages: 1.4
    Peter's Login Redirect: 2.7.2
    Print Friendly and PDF: 3.3.4
    Really Simple CAPTCHA: 1.7
    Search By SKU - for Woocommerce: 0.5
    Send From: 1.3
    SendPress: Email Marketing and Newsletters: 0.9.6.4
    Share Buttons by AddToAny: 1.2.7.5
    Simple User Password Generator: 2.0.2
    Smart Manager for e-Commerce: 3.5.3
    TinyMCE Advanced: 3.5.9
    User Role Editor: 4.7
    User Switching: 0.8.4
    WooCommerce: 2.0.20
    WooCommerce Admin Bar Addition: 2.4
    WooCommerce Catalog Visibility Options: 2.3.2
    WooCommerce Checkout Manager: 3.5.81
    WooCommerce Customer/Order CSV Import Suite: 2.2
    WooCommerce Custom Status: 1.0
    WooCommerce Dynamic Pricing: 2.3.9
    WooCommerce Local Pickup Shipping Method: 1.0.1
    WooCommerce Predictive Search LITE: 2.2.0
    WooCommerce Print Invoices & Delivery Notes: 2.0.2
    WooCommerce Product CSV Import Suite: 1.8.3
    WooCommerce Restrict Categories: 3.4.1
    WooCommerce Shipment Tracking: 1.1.11
    WooCommerce Table Rate Shipping: 3.2
    WooCommerce Video Product Tab: 2.3.1
    WooDojo: 1.5.4
    Woo Product Importer: 1
    WooSidebars: 1.3.1
    WooThemes Helper: 1.2.1
    WP-Filebase: 0.3.0.02
    WP-Mail-SMTP: 0.9.4

    CURRENT THEME:

    Hustle: 1.1.14

    ### End System Info ###

  9. WooUser
    Member
    Posted 1 year ago #

  10. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    I will discuss this with our developer team and see if they have any ideas as to what may be causing this. If you could, please let me know which plug-in created the dealer role that you're trying to sync. Also, try creating a synced list from a different role and see if you have the same problem.

  11. WooUser
    Member
    Posted 1 year ago #

    the plugin is called "user role editor".

    yes, i have about 10 lists, all having the same problem.

  12. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    We think the issue is the user role editor plugin. We are going to investigate that plug-in see if we can find a solution. We think that because it allows users to be in multiple roles we are only syncing one of their roles. Just a theory at this point. If you can remove the plug-in, I think synchronization will work. But if not, we will update you when we are able to find a solution.

  13. WooUser
    Member
    Posted 1 year ago #

    sorry, can not remove the plugin as it is an integral part of how i use the website... please keep me updated! Could really use the feature.

    Thanks

  14. WooUser
    Member
    Posted 1 year ago #

    hi, have you work ed on this at all?

    It's really a shame this feature isn't working for me, as i could certainly use it!

    thanks :)

  15. Josh Lyford
    Member
    Plugin Author

    Posted 1 year ago #

    hi ddjg,

    we are making some adjustments to how the sync runs. It should be one of the next upcoming releases.

    Josh

  16. WooUser
    Member
    Posted 1 year ago #

    awesome, thanks Josh!

  17. WooUser
    Member
    Posted 1 year ago #

    hey guys, the new update mentioned updated sync, but this unfortunately did not fix the issue on my end just so you know.

  18. Josh Lyford
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ddjg,

    I had the same thing happen to me on one of my sites. I am working on fix for it and i will let you know when it done.

    Josh

  19. WooUser
    Member
    Posted 1 year ago #

    thank you!

  20. fotonuntabrasov
    Member
    Posted 1 year ago #

    Try to use another plugin, like this one: http://wordpress.org/plugins/mailchimp/

    [ Signature moderated. ]

  21. WooUser
    Member
    Posted 1 year ago #

    thanks, but Mail Chimp is completely different than the sendpress plugin, and this is a support thread for Sednpress.

  22. joesell89
    Member
    Posted 1 year ago #

    I seem to have the same problem on my site. I have submitted a ticket through the SendPress support system.

    It would be nice to see this fixed.

  23. itdoug
    Member
    Plugin Author

    Posted 1 year ago #

    This will be fixed in the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SendPress Newsletters
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.