User Role Editor
[resolved] User roles not showing up under remove, and not being made available to plugins (4 posts)

  1. Wombat
    Posted 3 years ago #

    Here's the issue. I created a number of customer user roles awhile back, with a previous version of this plugin--about three months ago. Now, when I go to the user role editor, I find that when I create a NEW user role, it shows up for other plugins, but the ones that I have now do not.

    I tried creating copies of new roles, with the intention of deleting the old ones afterwards. Problem now is--none of the defined roles are showing under the "Remove Role" dropdown in the plugin settings page. So I can't delete them.

    I tried editing the serialized data in wp_user_roles, even very meticulously and with a fine-toothed comb, but it screws things up every time.

    I also tried optimizing and repairing my database, re-installing wordpress, deactivating, deleting and reinstalling the plugin... not sure what other options I may have here. Please advise.


  2. Vladimir Garagulya
    Plugin Author

    Posted 3 years ago #

    In order remove unneeded role you need to exclude all users from it, 1st.
    After that you will see it at the "Remove Role" dropdown menu.

  3. Wombat
    Posted 3 years ago #

    Excellent! Problem solved :) Thank you.

  4. Wombat
    Posted 3 years ago #

    Suppose I should mark this as resolved!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • User Role Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic