Support » Plugin: Notification - Custom Notifications and Alerts for WordPress » User registration “New Pasword Setup Link”

  • Resolved willaxa

    (@willaxa)


    Hello,

    It seems the link that generates {user_password_setup_link} contains an invalid token?

    https://imgur.com/a/vRhxKF5

    But the one generated by WordPress works:

    https://imgur.com/a/3TSOpyO

    Shouldn’t the link be the same?

    I really hop it works.

    —-

    BTW I’ve been searching for a way to disable the WordPress Notification

    [Website] Your username and password info

    No luck after spending hours using plugsin and custom code on functions.php

    ANy help would be appreciated.

    Thanks so much!
    wiL

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Kuba Mikita

    (@kubitomakita)

    The default WP email is exactly the reason why link sent via Notification plugin doesn’t work. It just overwrites the key.

    I suggest you disable the default WP notification and actually, in te latest version we released the disabled. Just head over to Notification -> Settings -> Integration and adjust the checkboxes

    Hope that helps!

    Thanks Kuba,

    Tried that. Here’s my settings.
    https://imgur.com/a/3oiJrGE

    When registering a new user I get this error though.

    Error Details
    =============
    An error of type E_RECOVERABLE_ERROR was caused in line 62 of the file /home/startu48/startupweb.me/wp-content/plugins/notification/class/Defaults/Trigger/User/UserRegistered.php. Error message: Object of class WP_Error could not be converted to string

    What do you think?

    Thanks,
    wiL

    • This reply was modified 1 month, 3 weeks ago by  willaxa. Reason: Adding screenshot
    Plugin Author Kuba Mikita

    (@kubitomakita)

    Damn it, another error 🙁 sorry

    New version released and I’m sure this time it will be fine.

    Thanks so much.

    That worked. 🙂

    Just wondering if New User is triggering both
    – User password reset request (FIRST)
    – User registration (SECOND)

    Plugin Author Kuba Mikita

    (@kubitomakita)

    Hmm it could be as these two uses the same low-level WP functions.

    Let me check that.

    Thank you so much.

    I created accounts for my clients and they all replied that they didn’t asked to reset password. 🙂

    Plugin Author Kuba Mikita

    (@kubitomakita)

    The issue has been confirmed and resolved in version 6.1.5 🙂

    PS. If you’ll have more questions or issues (hopefully not!) please open a separate thread for each. It’s easier to track them. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.