Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » User Registration Form not working as expected for logged in users

  • Resolved adriannees

    (@adriannees)


    The user registration form does not work if the user is already logged in – which you may be saying “duh” but two things to consider:

    1) you have a toggle for “enable logged in submission only” which makes no sense if it wont work for logged in users
    2) I want to use this to allow my existing users to add NEW additional users. We run a multivendor marketplace on WordPress and vendors need to be able to give their existing buyers accounts without going through us every time. By enabling logged in submission only we can block bad actors from creating fake accounts, so we’re not concerned about that.

    Adding to the confusion the form acts as if it works for logged in users, doesn’t throw up any error messages and shows the confirmation flag indicating that the user was successfully added. It also sends the confirmation email.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @adriannees

    I hope you’re well today!

    Well, it is actually a “registration form” only and it indeed doesn’t work for logged in users. You did make a valid points though.

    The “enable logged in submissions only” option would be more of an “overlooked” option rather than anything else – as it’s an option that was there from the beginning for other forms, before “registration forms” were introduced. It should be taken care of though.

    I also see the point in the scenario that you described.

    I’ve passed your feedback over to our developers so they’d looked into it to see how this could be addressed in future releases.

    Best regards,
    Adam

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @adriannees ,

    I’m sorry for the misinformation on our end. The feature that allows registering new users by already logged in users was not working because of the bug.
    It will be fixed in 1.13 version of the Forminator.

    kind regards,
    Kasia

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello there @adriannees

    I hope you are doing well!

    We haven’t heard back from you for a while now so we’ve marked this ticket as resolved. As Kasia has mentioned the issue will be fixed in 1.13 version of the plugin.

    If you do have any followup questions or require further assistance feel free to reopen it and let us know here.

    Kind regards,
    Nastia

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.