Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » User Registration Form Fields not saving to database.

  • Resolved michaelchuchro

    (@michaelchuchro)


    I am having an issue with the registration form transferring it’s field values into the user account profile. When a user register the only information that is saving is their username, password, and e-mail address. Their First and Last names along with other custom fields are not saving. when you look at the users through the WP Admin side the first and last names are blank. When you edit a profile through the cog icon on a profile page, the name and custom fields from the registration form are blank. A user is able to renter all the information and then save the profile. When that is done the information saves to the DB and displays on the profile.

    Here is a link to the affected registration form;
    http://www.chicagocop.com/register-account/

    I have search high and low and can’t find a support topic on this. Any help is appreciated. I am also running the current version of the plugin and wordpress. This problem just started to occur after I moved the WP instance to a new server.

Viewing 6 replies - 1 through 6 (of 6 total)
  • WhoTnT

    (@wpwho)

    I’m having a similar issue as well. I have the username, email, and nickname fields on my form. The strange thing is that the nickname saves when I register using my desktop and mobile phone but not on my laptop(all devices on the same network). I only detected the issue because a user registered and posted a comment stating that their nickname is not showing. For now I have the annoying task of updating the nickname manually for each new user by looking at the new user account email which displays the nickname correctly. I’m working on finding a solution but UM coding is so hard to trace with all actions and filters being used.

    WhoTnT

    (@wpwho)

    I finally tracked the problem down to the database caching in W3 Total Cache. I had to disable it to get the nickname to save. I’m not sure if that is the same problem you might have.

    Thread Starter michaelchuchro

    (@michaelchuchro)

    I tried disabling the database cache but that did not solve the issue for me. Still trying to figure it out, very frustrating especially with the other issues I’m having with this plug-in.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @michaelchuchro,

    This issue may be caused by plugin or theme conflicts.
    Can you please try to do a quick conflict test and see if the issue goes away?
    Please see our doc on how to do a conflict test.
    How to do a plugin/theme conflict test?

    Regards.

    Thread Starter michaelchuchro

    (@michaelchuchro)

    Hello,

    Well I tried a conflict test and disabled every plugin except Ultimate Member and still have the same results. I forgot to mention in addition to the standard WP user fields only one custom field “Agency” gets stored while the other two do not.

    Thread Starter michaelchuchro

    (@michaelchuchro)

    Hello again,

    Ok, I figured out the issue with the custom fields nots saving, It was rather simple to fix. Somehow the two fields were duplicated on the profile page. That is the fields on the registration form, although labeled identically were different from the ones on the Profile page, which is why the information wasn’t displaying.

    That just leaves me with the issue of the first and last name not saving to the WP backend. When you view the users through the Users tab on WP the first and last name are not stored when the account is created. However the username and email are getting stored. I did use the predefined fields on the UM registration page. Conflict test conducted with UM as the only active plugin with the same results.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘User Registration Form Fields not saving to database.’ is closed to new replies.