Support » Fixing WordPress » User profile silently fails to update if email addres malformed

  • Version 5.7.1
    Theme: extension of TwentyFifteen
    When editing a user profile, if the email address is malformed or blank, the Update function silently fails. There is no error message and the offending field is not given focus.

    Malformed could be:
    Missing the @
    A blank within the email address.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Vlad T

    (@vladytimy)

    Hi, @trevortokes

    Are you talking about editing users at wp-admin/users.php ? or on the front end (I’m thinking about some plugins that add the ability to edit user details on the front end).

    I cannot replicate your issue at wp-admin/users.php. I get the following errors:
    erros-email

    This may be a plugin or theme conflict.

    Please attempt to

    • disable all plugins
    • switch to a default theme (Twenty Twenty-One)

    If the problem goes away, enable the plugins one by one to identify the source of your troubles.

    As an alternative, if you want to make these changes only for your eyes, without affecting normal visitors to your site, install Health Check Plugin

    1. Under Tools > Site Health, on the Troubleshooting tab, click on the Enable Troubleshooting Mode button to disable all plugins and change the theme to a default one (just for yourself, while you’re still logged in).

    2. Then, by using the options displayed at /wp-admin, you can turn on/off plugins and themes, one at the time and check what plugin is the cause of your problem.

    3. Don’t forget to Disable Troubleshooting Mode when you’re done.

    See https://make.wordpress.org/support/handbook/appendix/troubleshooting-using-the-health-check/ for more information.

    Hope this helps,
    Kind regards!

    Thread Starter trevorstokes

    (@trevortokes)

    Thanks.
    I deactivated every plugin and then the theme.
    After the theme was changed I noticed the red bar and error message

    Error: The email address isn’t correct.

    or
    Error: Please enter an email address.

    But, after I reactivated everything (I kept careful notes to make sure I had all of the same active plugins) it still worked.

    Now I’m wondering if I (and our Membership Director) missed the error message all along, or if simply re-activating a plug in did something.

    Thanks for your help, and sorry if I troubled you with a non-issue!
    Regards

    Vlad T

    (@vladytimy)

    I’m glad it works now.
    No worries. You can always ask our volunteers here when in doubt. We’ll try to replicate and if it is a general issue will report it upstream so it can be fixed.
    Regards!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.