Support » Plugin: WP User Manager - User Profile Builder & Membership » User Profile Screen a few issues

  • Sorry had to repost this as my username changed and the post got locked…

    Hi,

    I have a new installation of the plugin most things work, registration, profile page, login etc.

    The profile page opens fine which is
    http://intranet/wordpress/index.php/profile/

    1. If i click on the “About” button on that page i get a page not found, the page it is trying to get to is
    http://intranet/wordpress/index.php/profile/admin/about

    2. In the wordpress admin screens in the user menu, your plugin has added a link “View Profile” but if i click that again it gets a page not found error the link is pointing to
    http://intranet/wordpress/index.php/profile/admin

    3. on your normal profile page that does open there are no options there to view other profiles which i believe there should be?

    Any help on this would be really appreciated

    thanks

    Richard

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Alessandro Tesoro

    (@alessandrotesoro)

    Hi Richard,

    Is your permalink settings, set to display index.php on all pages? Can you try setting the permalinks to “post name and see if it works in that way?

    Regarding your question n3, can you show me a screenshot of what you see?

    Hi,

    Thanks for the reply, sorry for the delay i did not receive an email notification, it got caught in my spam queue.

    Changed it to “post name” as you suggested and has on the whole fixed the loading profile, all usernames without spaces now work.

    The ones it does not find now is if there is a space in the username, so for example..
    “Deb Ives” if you click your link it tries to load http://intranet/wordpress/profile/Deb+ives so fails on a 404, if i take the “+” out and reload then it displays ok with this url
    http://intranet/wordpress/profile/Deb%20Ives

    With regards to q3, how do i post a screenshot here as i cant see the upload option?

    thanks

    • This reply was modified 2 months, 2 weeks ago by  gingellr.
    • This reply was modified 2 months, 2 weeks ago by  gingellr.
    • This reply was modified 2 months, 2 weeks ago by  gingellr.
    • This reply was modified 2 months, 2 weeks ago by  gingellr.
    Plugin Author Alessandro Tesoro

    (@alessandrotesoro)

    Hi there

    I did some further tests on my end and I can’t seem to replicate the issue with the spaces within usernames. Are you using the latest version of WPUM? This was an issue solved a few months ago and profiles should load fine both with a + and %20 in the urls. Are you 100% sure that “Deb Ives” is a username and not a nickname? Under permalinks settings -> User profiles permalink base do you have username set?

    Regarding the screenshot, you can upload it somewhere like dropbox, or imgur or imageshack or any other online hosting, unfortunately WordPress.org doesn’t allow attachments :/

    Hi Alessandro,

    I am using Version 2.0.8.
    “Deb Ives” is definitely her user name her nickname for example is “debs” i have a few user names with spaces and none of them display the profile page.

    the user profiles permalinks is set to “Display Username”.

    As i say all the other users work fine just not the ones with spaces in the user names.

    ….here is the screenshot of a profile page.

    https://www.dropbox.com/s/c7jvh798y0ek598/userprofile.JPG?dl=0

    thanks

    Plugin Author Alessandro Tesoro

    (@alessandrotesoro)

    Regarding the first issue, can you send an email to support@wpusermanager.com so I can provide better help from there?

    Regarding the 2nd issue, you need to enable the other content within the plugin’s settings. In users -> settings -> profiles -> profiles content

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.