• Resolved sammyham

    (@sammyham)


    The Users have blank profile pics even though they have a pic on their profile and ERP employee profile has a pic. Looks like WP Project is trying to pull image from Gravatar instead of the site itself. How can this be fixed? It is very annoying.
    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Mazhar

    (@emazharulislam)

    Hello @sammyham,

    I think you are missing something about the Project Manager user’ avatar and WP ERP employee’s profile picture. Actually, Project Manager shows the gravatar image instead of showing the ERP’s employee profile picture. Project Manager/WP ERP doesn’t have such integration or option for showing WP ERP employees profile picture as a Project Manager user’ avatar.

    Thread Starter sammyham

    (@sammyham)

    Actually Project Manager does not show the gravatar or the profile pic that user has uploaded to their profile on their account. It will only show a profile pic if they have a gravatar pic. Not everyone uses Gravatar. By using the pic on the site whether it be the site profile pic or the ERP Profile pic it would be more cohesive instead of a everyone having a gravatar pic on backend and then a different profile pic on front end. You must admit two different pics is very annoying.

    Mazhar

    (@emazharulislam)

    Although I have noted your thought, I like to clarify something. Actually by default WordPress doesn’t allow the user to upload avatar/profile picture. The user needs to use gravatar to set profile picture. If we fetch the profile picture from WP ERP, those who don’t use ERP they will get a blank profile picture. That’s why the Project Manager shows a profile picture form gravatar.

    Thanks.

    I totally agree with the poster. It’s a horrible user-experience to demand that a new client, who just wants to be friendly and upload a photo, must instead be told to go away and upload it on some other website?

    What?

    And then, whenever he posts anything, anywhere, on any WP blog, it will post his or her photo? That’s not a feature, that’s a bug, and totally unprofessional.

    Can you at least give an option to use cartoon avatars, or let us remove the option entirely, rather than having ugly blank placeholders everywhere?

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘User Profile Pic Not Working’ is closed to new replies.