Support » Plugin: 2FAS - Two Factor Authentication » User not found

  • Resolved kirksmacdonald

    (@kirksmacdonald)


    Hello i have been using this plugin for over a month with no problem

    You updated the plugin two days ago and now

    we cant login it says user not found when previously we had no problems before this update

    i tried to reset up the user still the same problem

    i have to turn the plugin off to login please advise

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author 2FAS

    (@2fas)

    Did you do any update related to users before you update the plugin?
    It looks like the id that has been associated with the user in our external api has changed. How did you reset the user?
    In our last update there was nothing related to users, only the SDK update, method of plugin authentication in the API and adding language support so this issue is very strange.
    Can you turn on error logging in admin settings and try to generate this error, then maybe we receive more details.

    ok i have just did this,

    i turned on the error logging

    i deleted the user in the authenticator app i use

    i set up the user i was currently logged in as in the authenticator app i use

    and again the same problem

    also if i try to enter the one time back up code i instantly get this when i click on the link

    ERROR: The username field is empty.
    ERROR: The password field is empty.

    it would seem i have found the problem

    i have also installed

    Advanced Access Manager 6.3.3

    if this is switched on 2fa does not work

    ok now i have to try to find how to make them both work together

    ok i have solved the problem

    Thank you for your support

    Plugin Author 2FAS

    (@2fas)

    Can you provide more informations what cause this error and how you resolve it?
    This information can be valuable to us to be able to react in similar situations.

    Ok i have Advanced Access Manager installed

    the problem was this i had to turn the user level filter off this is the description of what it is thats all i can tell you

    User Level Filter
    Extend default WordPress core users and roles handling, and make sure that users with lower user level cannot see or manager users and roles with higher level.

    im not sure exactly why it causes a problem and have tested it several times to make sure that switch is definatly causing the problem

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘User not found’ is closed to new replies.