Support » Plugin: BuddyPress Activity Plus » Unable to post link after clicking Preview button

  • Resolved tedmaster

    (@tedmaster)


    (Thanks in advance for adding these features!)

    Summary

    There are a number of issues that arise when trying to post links. The issues range in form and function from two Cancel links/buttons to failure to load previews (possibly related to failed 301 redirects, among other potential issues). Because the issues vary depending on the URL, I’ll only use https://missoulaweb.design/ as my test URL.

    Preconditions

    • WordPress 4.9.4
    • Customizr theme 4.1.19
    • BuddyPress 3.2.0 with nouveau theme
    • BuddyPress Activity Plus 1.6.4
    • BuddyPress Members only 1.9.3 (but same happens with this plugin deactivated so probably not related)
    • Viewing the New Post form with the cursor in the post message field

    Steps to Reproduce

    1. Enter text in the post message field
    2. Click the Link icon to display the URL field
    3. Paste the URL into the URL field
    4. Click the Preview button (expected result is that the preview is shown, and it is)
    5. Scroll down a little to click Add link button

    Expected Result

    • Preview is still shown

    Actual Result

    • Preview turns to “There has been an error processing your request”
    • There are two Cancels (one a link, the other a button) – these are present from before, in fact
    • Clicking “Add link” button clears the form and fails to post the link

    Workaround

    • At step 4, click next to the Preview button (on the grey background, for example) to trigger the onchange event (or similar). The preview should fail with the error above.
    • Click the Preview button. The preview should load.
    • Click the Add link button and the link should post correctly.

    Notes

    • Once the link does actually post, it does not appear to have the standard post styles applied to it. Here is an example of what I’m seeing: https://48h.pics/SxkrxS30 (only valid for 48 hours from time of this post). Refreshing the page shows the post properly.

    Not being familiar with how you are getting the preview, I think you might need to add -L (if it were via cURL) to follow redirects. You might also consider adding -k (skip SSL validation) but show a warning that the site is insecure. Also, I would remove the onchange event and only set the preview when the user clicks the preview button as it seems to be causing more issues than it solves.

    Thanks again for the hard work and the helpful plugin. I hope this bug report makes it easy for you to find and fix the issue.

    Kind regards,

    Ted Stresen-Reuter

    • This topic was modified 2 years, 1 month ago by tedmaster.
    • This topic was modified 2 years, 1 month ago by tedmaster. Reason: Clarified using nouveau theme and the members only plugin
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tedmaster

    Hope all is well!

    There has been an error processing your request

    I could not reproduce the above error on my end. Please let me know, is this happens with every link you’re trying to share or with only one certain link?

    If this happens with any link, it is possible that there might be a conflict with another plugin. Deactivate all other plugins and test if the same error still will be showing. If everything is well, activate one plugin at a time to find the one that causes this.

    Follow the steps from the flowchart:
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Once the link does actually post, it does not appear to have the standard post styles applied to it.

    I could reproduce the issue with styling and have informed our developers about it.

    Please advise,

    Cheers,
    Nastia

    Hi Nastia,

    Thanks for the reply. To answer your questions, no, it doesn’t happen with every URL but it does with the one I sent: https://missoulaweb.design/. Also, I noticed that with others (http://yahoo.com, for example) we have an even worse experience (nothing happens, blank screens and such – I can write up a more formal report but it could take a while…)

    I would rule out plugins as I indeed tested with only the BuddyPress and BuddyPress Activity Plus plugins installed.

    And thank you for forwarding on the formatting issue. Although it is only a cosmetic issue, users think the site is broken when they see things like that.

    Kind regards,

    Ted Stresen-Reuter

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @tedmaster

    I trust all is well!

    I have tried the URL shared https://missoulaweb.design/, on my end. Although I still could not reproduce this issue with default WordPress theme (2017). Same with the Customizr theme 4.1.19

    Would you please enable WordPress debugging by putting the following to the wp-config.php file:

    
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    

    Make sure that you insert these lines above /* That's all, stop editing! Happy blogging. */.

    Please reproduce the issue on your site. This way all errors will be saved in the debug.log file inside the /wp-content/ directory.

    Share with us the errors from debug.log file and let us know what PHP version is running on your site.

    Please advise,

    Cheers,
    Nastia

    Hi again.

    I just tried it again and now it’s working. It’s very odd because it was happening consistently enough for me to be able to document it. I have no idea what’s changed since I posted this. Regardless, at least the formatting issue is reproducible as are the two cancel links.

    Thanks much for looking into this.

    Kind regards,

    Ted Stresen-Reuter

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @tedmaster

    I’m sorry for the late response here and appreciate the feedback on this.
    Have you made any changes in the plugins you were using maybe?
    Or any other setting that could reflect on this?

    As for the reported issue, we’ll keep you posted here as soon as we’ve got some insights from our developers.

    Warm regards,
    Dimitris

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to post link after clicking Preview button’ is closed to new replies.