Support » Plugin: WP Page Numbers » User level functions now depreciated, causes error

  • Hi there,

    I just wanted to let you know that when you install this plugin on a WP 3.0+ you will get an error like this:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.

    As far as I’m able to tell, this is because in the older version user groups were used to determine abilities (admin, editor, etc). The new versions are using “user capabilities” (can add post, can publish, etc).

    The error should be avoidable in WP 2.0 because it supports both of these methods, but it is deprecated post WP 3.0.

    http://wordpress.org/plugins/wp-page-numbers/

  • The topic ‘User level functions now depreciated, causes error’ is closed to new replies.