Support » Plugin: Debug Bar » User level code deprecated – is this an error?

Viewing 1 replies (of 1 total)
  • The current_user_can() function itself is not deprecated.

    The notice you’re receiving is because there’s a plugin/theme somewhere in your system that, instead of checking user capabilities with something like current_user_can( 'manage_options' ) is using the numerical user levels, like current_user_can( 7 ).

    The numerical user levels were deprecated a long time ago, but some plugins/themes still use them.

    http://codex.wordpress.org/Roles_and_Capabilities#User_Levels

Viewing 1 replies (of 1 total)
  • The topic ‘User level code deprecated – is this an error?’ is closed to new replies.