Support » Networking WordPress » User level 10 but no access to SuperAdmin Panel

  • Resolved perezdi


    Hi, there!

    I’m no php artist but I’ve been handling WP for over three years pretty well, recently I came here to ask a bit of help because of a server change that didn’t really worked out. So I’m kinda not a noob user but not really a programmer. Hope this helps a bit to deal with the explanation over here. πŸ™‚

    The thing is, recently, after upgrading to 3.4.1 I noticed that the SuperAdmin Panel is not there. I tried to go in the [site]/wp-admin/network with the accounts that are SuperAdmins but all of them seem to don’t have access anymore. Every SuperAdmin account receive the “you don’t have permission to access this page” message.

    I dug in some old threads to look for an answer and did deactivate my plugins to update WP for 3.4.1, also, tried to deactivate all the plugins to see if it was going to solve it and nothing change and also checked out for the tables that should be there and all of then are.

    Also, I check the database for the userlevels and both SuperAdmins are userlevel 10.

    I didn’t find any solution after some hours of research so I’m here to ask for the ‘Sword of omensο»Ώ give me sight beyond sight’, πŸ˜‰

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Ipstenu (Mika Epstein)


    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Thunder-Thunder-Thunder Cats HO!

    Have faith Lion-o, the secret is in your Database.

    Go into wp_sitemeta and look for site_admins

    In there you will see something like this: a:1:{i:0;s:7:"Ipstenu";}

    That is the secret to defeat Mum-Ra. Yours would be a:1:{i:0;s:7:"perezdi";}

    However if you wanted to add WileyKit instead it would be a:1:{i:0;s:8:"WileyKit";}

    Capitalization and stringlength matter. Add one user, and use him to restore the power to the eye on Thundar.

    Ok, Mika. Going for it. I’ll let you know any advance.

    It should be ogligatory for now on to use metaphorical comparisons on the forum. πŸ˜€

    I have this:


    By “inserting another user” you didn’t just mean on the wp_sitemeta > siteadmins, right? I think not so how I would be able to login, eh?

    I’m going for this process then:

    Question: what’s that ‘N’ doing there before ‘liono’?

    I changed to this:

    Let’s play that I just add ‘swordofomens’ using the above process through that link.

    But it didn’t work out. The new account receives a message “You don’t have enough permissions to see this page”.

    Moderator Ipstenu (Mika Epstein)


    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Actually make it just this: a:1:{i:0;s:11:"swordofomens";}

    Then try to log in as swordofomens (If it’s SwordOfOmens, use that in the code)

    I just did it with a previous superadmin account.

    Now everything is working fine. Time to slash some Mutants of Plundarr now.

    Thank you, she-elf.

    Moderator Ipstenu (Mika Epstein)


    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    Not a problem πŸ™‚

    (FWIW, the reason I always just add one person in to rebuild, is that I seem to always goober the syntax for more than one. One is easy and safer, if time consuming.)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘User level 10 but no access to SuperAdmin Panel’ is closed to new replies.