Support » Plugin: Site Kit by Google » User Doesn’t Have Sufficient Permission

  • Resolved wonka2

    (@wonka2)


    I’m trying to use SiteKit with my site but I’m running into an issue. Under Search Funnel and Popularity, it says:

    Data error in Search Console
    User does not have sufficient permission for site ‘https://mydomain.com/’. See also: https://support.google.com/webmasters/answer/2451999.

    I checked out the provided link but couldn’t figure anything out. On search console, my root domain mydomain.com is working… Sort of, the info I’m seeing is different than in Google Analytics.
    I’m really new to this… Can someone please help me out?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Renee Johnson

    (@reneesoffice)

    Hi @wonka2, thanks for opening a topic! Let’s check a few things:

    1) Did you verify the site on Search Console before Site Kit ?

    2) Do you have ownership and administrative access to the site (https:// if that applies for your site) in both Search Console and Analytics? See our documentation to understand permissions levels.

    wonka2

    (@wonka2)

    I’ve got my root domain verified on Analytics and Search Console…

    Plugin Support Renee Johnson

    (@reneesoffice)

    @wonka2 Thanks for following up! How did you verify the domain in Search Console- did you use any of these methods?

    I cannot be certain without more details, but I would advise checking that the admin settings for the property in Google Analytics and Search Console reflect the same exact domain (https:// if you’re serving your site over https://) and that you have full admin and owner permissions for it.

    Site Kit checks what permissions your Google account has on those services, so the root problem seems like it would in the settings of those services.

    Plugin Support Renee Johnson

    (@reneesoffice)

    Hi @wonka2 ! I see you’ve opened a new topic. Were you able to check your settings in Search Console and Google Analytics as mentioned above too?

    Hola, tengo el mismo error, en Search Console tengo verificado por dominio y en GA tengo verificado por https ¿Qué puede estar pasando?

    The same problem occurred to me. I had verified only the domain property. I then verified https://mysite.com and the problem was solved.

    thanks, @umersoftwares that was the issue, it seems to be working now although I took no action, not sure what caused it to suddenly work

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘User Doesn’t Have Sufficient Permission’ is closed to new replies.