Support » Plugin: GamiPress » User didn’t earn points after replying to a topic

  • Resolved demonboy

    (@demonboy)


    Hi,

    I’ve set up my points type to award 10 points when any user replies to any topic, but I noticed one user didn’t get his 10 points by answering a topic in one forum. I wanted to check that I had set this up correctly:

    When: reply to a topic – 1 (times) limited to – Unlimited
    Earn: 10 points – with a maximum number of times to earn it – 0

    Am I correct in saying that this is allowing a user to earn 10 points at any time he replies to a topic in any forum? Or is this only dishing out 10 points once?

    I’ve created an alternative:

    When: reply to a topic – 1 (times) limited to – 10 times – Daily
    Earn: 10 points – with a maximum number of times to earn it – 0

    Is this doing the same thing, but only allowing them to earn ten points ten times in a day?

    One thing that occurred to me was that I had originally set this up to only allow points when answering a topic within a specific forum. I edited it to any topic in any forum. Is there a chance WP didn’t update this change, even though I see the update in the back end?

Viewing 1 replies (of 1 total)
  • Plugin Author rubengc

    (@rubengc)

    Hi @demonboy

    Yes, exactly this field is to limit it in a period time

    You can check an explanation of how this field works here:
    https://gamipress.com/docs/tutorials/how-the-awards-engine-works/

    Regarding your latest points, were you talk about that you have changed the setup of a points awards, your users won’t get awarded the points they should earned in the past because GamiPress doesn’t makes retroactive checks for setup changes

    Best regards

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.