Support » Plugin: SportsPress - Sports Club & League Manager » User already has more than ‘max_user_connections’ active connections

  • My site keeps crashing with the following error message:

    Warning: mysqli_real_connect(): (HY000/1203): User wp_ten1 already has more than ‘max_user_connections’ active connections in /hermes/bosnaweb20a/xxxx/xx.xxxxxxxx/public_html/mywebsite/website/wp-includes/wp-db.php on line 1612
    User wp_ten1 already has more than ‘max_user_connections’ active connections

    My webhost is telling me that the Sportspress script is executing queiries but not closing the database afterwards. Is this possible? Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Savvas

    (@savvasha)

    Hi @sirflex10 ,

    Did you try to disable ALL your plugins except SportsPress and switch to a default theme like ‘Rookie’ or ‘TwentySeventeen`?

    Thanks,
    Savvas

    I have not because one of the plugins is a caching plugin. (W3 Total Cache) But I will try that now, monitor it and reply back with the outcome. Thank you.

    I have disabled all plugins except the sportspress plugin and I have switched to the default rookie theme but I am still getting the error. To resolve the error I create a new db user. I do not know what the limitation is on max_user_connections but I’m under the assumption that the database is being opened and not closed. I cannot figure out how to view current connections and our concurrent connections. 🙁

    Plugin Contributor Savvas

    (@savvasha)

    Hi @sirflex10 ,

    I am really sorry for that situation. I am pretty sure that is an issue of your server (probably strict settings of MySQL server?). Is it possible to try with a different hosting to see if you are still getting the error?

    SportsPress is using mainly native WordPress functions, so you should ask from your current host to increase the max_user_connections value.

    Check the MAX USER_CONNECTIONS setting on your MySQL server for the user. In PHPMyAdmin go to the server page (Click on the Server:<>) and in the sub-menu click on priviledges. Edit the user dbo343879423 and the MAX USER_CONNECTIONS will be on the right side. By default I believe it is set to 0 (unlimited), yours maybe restricted depending on who setup the server.

    From https://stackoverflow.com/questions/4079531/mysqli-error-user-already-has-more-than-max-user-connections-active-connectio

    Thanks,
    Savvas

    Thank you for your feedback. I agree with you and I suspect the hosting provider as well. My hosting provider has informed me that the maximum value for max_user_connections is 30 but I’m not certain how to view my concurrent and or current connections. For example..does this mean that any time a website visitor visits the website and sorts a table is that creating a new connection?

    Plugin Support Roch

    (@rochesterj)

    Hi there!

    A caching plugin should help you with that, but maybe you’ll need some agreassive caching solution (creating static versions of your pages, for example) to avoid new queries.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.