Support » Plugin: WP-Backgrounds Lite » Useless – not working

  • I use Enfold WP theme – one of the top 3 selling WP themes. This WP-Backgrounds Lite plugin’s settings menu only has 5 fields: 2 fields for z-index, 1 for background color, 1 for content position and 1 for ID/class.

    There’s no option whatsoever for choosing random images for the background for all the pages and posts.

    I found out that one must assign the image in each single post and page. If you have 100 or more pages – it’s literally mission impossible and a huge waste of time.

    Then I found out that you only get to choose 1 image only.
    And on the top of it – it does not work, even after trying out all possible z-index variations.

    Many bugs – the fields that are supposed to contain default values, contain other values, etc.

    Verdict – this plugin is totally useless, and is only released in order to promote the author’s pro-version of the plugin, which, of course is not free. I’d strongly suspect that many of the good reviews of this plugin are not genuine.

    I now found a good background-slide plugin which is very lightweight, simple and effective – “Full Screen Background Images” ( It’s very recently updated and compatible with WP 4.0

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author InoPlugs


    Just a quick comment if someone else wants to use this plugin with Enfold. It definitely works with Enfold – in fact we’re working for Kriesi (forum administrator and head of support – ) and we test our plugins with his themes, especially with Enfold.

    1) Make sure you use a boxed layout of Enfold.

    2) Configure the plugin settings properly:

    Z-index value of background layer: 2
    ID or class of the content container/wrapper: #wrap_all
    Z-index value of content layer: 5
    Position of the content container/wrapper: relative

    Please, I am having the same problem with the same theme.
    I did as you requested in 1 and 2 above and still I am not having a transparent watermark background image in home page. Also, I cannot add more than one image so as to have a background slider.

    I have disabled the plugin for now

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Useless – not working’ is closed to new replies.