Support » Plugin: Kadence Blocks ā€“ Gutenberg Page Builder Toolkit » Use only Kadence Blocks Colors not working

  • Resolved Sebastian

    (@imcube7)


    Hi!

    In the Kadence Block Controls I defined a project specific color palette and turned on “Use only Kadence Blocks Colors?”. But when I enter a color setting in a new kadence block (for example the background color setting in the Background Settings of a Row Layout Block), the color picker is still available and a random color can be picked.
    Is there something else I have to configure to make the “Use only Kadence Blocks Colors?” function work?

    Another question: If I would define a custom color palette for the block editor the wordpress way, would the kadence blocks pick up this defined palette, or would I have to additionally set up the color palette for the kadence blocks?

    Thanks for your help!

    Best regards,
    Sebastian

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Is there something else I have to configure to make the ā€œUse only Kadence Blocks Colors?ā€ function work?

    Did you reload the page? After saving sometimes to get the color palette to update you need to reload the editor.

    It picks up whats added the default way and you can add to it or turn that off.

    Ben

    Hi Ben,

    yes, I reloaded the page and double checked all settings. Even if I set it to only use the Kadence Block Colors the color picker is still available. I don’t know why the setting is not working.
    So I manually added the theme support to disable custom colors ans that worked. The Kadence color palette now looks a little bit cut off at the top, but the palette is fully functional.

    Sebastian

    Hey, ok wait perhaps I am miss understanding what you want.

    The Color picker should always be there (unless you turn off custom colors), only using Kadence Blocks colors refers to the color palette which is a preset of color options. It won’t remove the color picker because you can always select a custom color (unless you turn off custom colors) it just defines which colors will be available in the color palette.

    Most themes define a color palette and by turning on our settings for Use only Kadence Blocks Colors its going to turn off the colors added by a theme color palette and only show the colors you select in the color palette.

    Does that make sense?

    Ben

    Hi Ben,

    yeah, I’m sorry. I misunderstood the meaning of the “Use only Kadence Blocks Colors” setting. I understand your decision to always keep the color picker present. For finished client projects I think it’s good to be able to lock the editing possibilities to the declared theme colors, or hide them completely. It’s fine to do this via theme support.

    It’s not a big deal, but maybe you can check, why the custom color palette doesn’t have enough padding at the top, when the color picker is removed via theme support. Maybe there is an easy fix that can be included in a next update. Or maybe you can tell me, how I can add the css give the palette a little more padding at the top. Just a cosmetic UI thing though.

    Thank you so much for taking the time!

    Sebastian

    Thanks for telling me about the UI thing, I’ll look at adding a fix for that.

    Hi Ben,

    thanks for the CSS fix you added in v1.7.3!

    Another thing that’s not working with the locked color palette:
    Some color options inside the Block Defaults settings don’t work.
    I made a list of my findings:

    Kadence Block Controls > Block Defaults >

    * Advanced Button > Design Settings
    * Icon List > List Text Styling & Icon Color
    * Advanced Heading > Heading Color

    = color setting opens empty box underneath, no color selection possible

    All other color settings inside the different Block Defaults settings seem to work fine with the custom locked color palette.

    Thanks for looking into this!

    Thanks for posting about this, I will look into it.

    Ben

    Thanks in advance!

    I just bought the Pro extension šŸ™‚
    Can I post questions in this support forum, or is there another forum for the Pro Blocks? I couldn’t find an appropriate section on the Kadence WP website.

    Sebastian

    hannah

    (@hannahritner)

    Hey Sebastian,
    You can post questions here: https://www.kadencewp.com/support-forums/forum/membership-forums/
    Hope you enjoy Pro:)

    Hannah

    Plugin Author Ben Ritner – Kadence WP

    (@britner)

    Hey,
    I was doing some testing and trying to recreate so I could fix this:

    Kadence Block Controls > Block Defaults >

    * Advanced Button > Design Settings
    * Icon List > List Text Styling & Icon Color
    * Advanced Heading > Heading Color

    = color setting opens empty box underneath, no color selection possible

    I wasn’t able to recreate. I see the colors available from the color palette I set there.

    Can you send a screen shot of your color palette and those settings?

    Can you tell me what version of WordPress you are using?

    Can you tell me if you have the gutenberg plugin installed?

    Ben

    Sebastian

    (@imcube7)

    Hi Ben,

    the current setups is WordPress 5.3, Gutenberg 6.9.0, Kadence Blocks 1.7.5, Custom Colors Disabled. But the problem already existed in the previous versions of all the above mentioned components.

    Here’s a link to a PDF I created with some screenshots:
    https://www.dropbox.com/s/0q3pp4rn6g7lb8h/kadence-color-settings.pdf?dl=0

    I hope this helps to find the problem. Thanks for the support!

    Sebastian

    hannah

    (@hannahritner)

    Plugin Author Ben Ritner – Kadence WP

    (@britner)

    Can you tell me what browser you are in? I just tried and three browsers and was unable to recreate.

    Ben

    Sebastian

    (@imcube7)

    Hi Ben,

    I’m working on Chrome Version 78.0.3904.108 on macOS 10.14.6, but I also tested it with the latest versions of Firefox and Safari.
    After extensive testing with possible conflicts with installed plugins, I can confirm that the issue is related to Gutenberg 6.9.0 being activated. If I deactivate the Gutenberg plugin, the color settings mentioned above work as expected. When I activate the Gutenberg Plugin, the color setting are blank again.
    What’s really strange about it is, that most of the color setting work as expected with the Gutenberg plugin activated. Only the three mentioned settings are blank.

    It would be great if you could try to replicate the issue and report back.

    @hannahritner This issue is not connected to the (now working) visibility settings in the block defaults. Thank you for your support!

    Sebastian

    Just to report back here:

    With Kadence Blocks v1.7.7 and Gutenberg v7.0.0 this issue is gone and the color settings are now visible for all block defaults.

    Thank you very much for your work! Greatly appreciated!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.