Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Use NextGEN Gallery on Nginx server

  • Hi to all.
    It is possible to use the NextGen on nginx server? Because I have a problem on view the slideshow gallery. This is an example of my gallery:

    Link

    If you try to access it redirect at article, and the “next” and “prev” buttons of the gallery doesn’t works.

    My permalink setting is: /%category%/%postname%.html
    My configuration nginx for the site is:

    server {
        listen *:80;
    
        server_name www.ntacalabria.it ntacalabria.it;
    
        access_log /var/log/nginx/wordpress.access.log;
        error_log /var/log/nginx/wordpress.error.log;
    
        root /home/ftp/wordpress;
        index index.html index.htm index.php;
    include /etc/nginx.wp/restrictions.conf;
    include /etc/nginx.wp/wordpress.conf;
    rewrite ^/sitemap_index\.xml$ /index.php?sitemap=1 last;
    rewrite ^/([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml$ "/index.php?xml_sitemap=params=$2" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml\.gz$ "/index.php?xml_sitemap=params=$2;zip=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html$ "/index.php?xml_sitemap=params=$2;html=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html.gz$ "/index.php?xml_sitemap=params=$2;html=true;zip=true" last;
    try_files $uri $uri/ /index.php?q=$uri&$args;
    try_files $uri $uri/ /index.php?$is_args$args /index.php?q=$uri&$args;
    ...
    }

    Thank you very much for your time I hope to find a solution 🙁

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author photocrati

    (@photocrati)

    @wikilab – We have many installations using Nginx but I cannot say what might be the issue with your particular installation.

    I can only recommend reviewing these articles to see if they are of any assistance:

    Unfortunately server configuration is a bit beyond our scope of support, if that is the root cause of the issues you are seeing.

    Aside from the navigation not working with the ImageBrowser display you have I cannot see anything “wrong” at a glance, have you tried using the Ajax Pagination option to see if that helps with the navigation issue?

    – Cais.

    Thank you for your reply. I have noticed that I have installed a plugin on my WordPress that redirect all 404 to the related article based of the word in the url; if I disable this plugin and I try to navigate in the gallery now i have the 404 error!

    My permalink setting is: /%category%/%postname%.html and the permalink slug for the NGG is nggallery

    Let me know if anybody know a solution for the 404 Error on gallery navigation

    Plugin Author photocrati

    (@photocrati)

    @wikilab – I don’t expect that Permalinks structure to be an issue, have you tried with just NextGEN Gallery active and temporarily switching to a default WordPress Twenty series theme?

    – Cais.

    Before to use Nginx server this configuration of wordpress worked really well on apache (no more plugins installed and the theme is the same).
    If i disable the permalink on wordpress i have 404 error in gallery navigation and if i try to create a new gallery I have 404 error
    POST http://www.ntacalabria.it/photocrati_ajax?action=upload_image&gallery_id=0&gallery_name=test 404 (Not Found)

    Plugin Author photocrati

    (@photocrati)

    @wikilab – That path to photocrati_ajax is not correct as it is not in the site root … finding what is pointing it to location (which may be in your server setup) may lead to the solution.

    – Cais.

    Ok but I try to configure my server following different topic on the web for example this solution but for me doesn’t work…
    On my server it remove the index.php/ before photocrati_ajax and I don’t know the why….

    I see on another server with apache and the url POST is the same but on NGINX i have 404 error….
    What you mean with

    …finding what is pointing it to location (which may be in your server setup) ..

    Thank you again

    @wikilab Server configuration is not a matter that can be dealt with the support forum of a plugin developer. If, as you say, your problem lies in the Nginx server configuration, check their official documentation, in addition to the reported above links. And/or their forum.
    If you can’t make it, hire a sys-admin.

    @tizz ok sorry 🙂
    Do you have expirience to do this? Can i hire you to do this? Let me know with private message
    Thank you

    @wikilab Sorry no, it’s not my job.

    Ok Thank you,
    I followed many tutorials to setup my nginx server for wordpress, all work fine only the NextGen gallery (upload pic and navigation album) doesn’t work….

    I hope that there are people that can help me.

    I have seen more people on here complaining about Next Gen when are the developers going to get the bugs out?

    @billts1, Aside from the fact that it is to be seen whether this is a bug or not (if you are convinced that it is, open a report bug with the description of the case), the developers are constantly working to try to improve the plugin.

    Is not my interest to create a discussion about the developer team of NextGEN I hope only that there are a solution to fix this error that appear only on NextGEN Gallery.

    Thank you

    Plugin Author photocrati

    (@photocrati)

    @tizz – Thanks!

    @wikilab – As noted, server configuration is well beyond the scope of support to be found in any plugin’s support forum. I would still recommend, as @tizz also suggested, you look into having someone help you who is directly involved with Nginx to ensure the server configuration is correct as much as possible.

    – Cais.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Use NextGEN Gallery on Nginx server’ is closed to new replies.