Support » Plugin: MC4WP: Mailchimp for WordPress » Use “groups” instead of “lists” for multilingual audience

  • Resolved dreamvim


    Hello there,
    I’m starting a multilingual (WPML) Woocommerce store integrated with Mailchimp.

    Almost everything is working fine, but there’s a thing that I can’t manage to set up:
    send user language information when someone subscribes from Registration or Checkout page.

    We use “groups” to define our language in Mailchimp, but a “radio button” custom field could be fine too.
    I also see a default “Language” field in my contacts info on Mailchimp, but it’s always empty.
    We CAN’T use multiple “Audiences” (lists) for this purpose, starting from the fact that the free version of Mailchimp does not allow to create further “Audiences”.

    I also tried the MC4WP official Extension for WPML ( but I can’t in any way use “Groups” instead of “Audiences”.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Lap


    I recommend sending in the site language via the MC4WP – WPML addon and NOT setting any list/audience per language / just leave those choices empty.

    Then in MailChimp you can create segments based on the language field.

    Hope that helps. If you have any questions, please let me know!

    Hello Lap,
    thanks for your guidance.

    I installed “MC4WP: WPML compatibility” by “ibericode”.
    then in WC4WP -> WPML i set as follows:

    I left “– use form or integration setting” for “Mailchimp list”
    I selected “Set the subscriber’s language based on the site language”

    At this point, in a guest window I registered a new user navigating the website in “English” and selected to subscribe the newsletter in the registration process.

    The new user is now added in my Audience, but the “Language” field is empty.

    What am I missing?

    I tried to create a segment based on the language field and effectively it seems to work… I just see the field empty but Mailchimp recognizes it correctly.

    I don’t know why Mailchimp behaves this way but I suppose my issue is solved.

    Thanks 🙂

    Plugin Contributor Harish Chouhan


    Hey @dreamvim,

    Thanks for the update. I just tested and did see the MC language field empty but the data was recognized. It might be a bug in their UI.

    Thanks for updating us though and if you have any further queries, please feel free to let us know.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Use “groups” instead of “lists” for multilingual audience’ is closed to new replies.