WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Use capabilities instead of deprecated user levels

[Resolved] Use capabilities instead of deprecated user levels

  • Hey there,

    Thanks for the useful plugin. When running with WP_DEBUG on, it throws a Deprecated warning, though. It’s because you are using a user level in your add_options_page() call.

    If you replace this:

    function zbp_add_pages() {
    	// Add a new submenu under options
    	add_options_page('zbPlayer','zbPlayer',6,'zbplayer','zbp_manage_page');
    }

    with this:

    // Add the script
    function zbp_add_pages() {
    	// Add a new submenu under options
    	add_options_page('zbPlayer','zbPlayer','manage_options','zbplayer','zbp_manage_page');
    }

    you should be good to go

    http://wordpress.org/extend/plugins/zbplayer/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Use capabilities instead of deprecated user levels’ is closed to new replies.