Support » Plugin: AMP for WP - Accelerated Mobile Pages » Use AMP without affecting the desktop theme?

  • Resolved iniciopublicxd

    (@iniciopublicxd)


    Hello, I have a problem, I would like to keep the view of the desktop theme, but when activating the Amp plugin, it redirects me to the mobile theme both for desktop and mobile view

    I just want the theme switf to go mobile while the original desktop theme is intact

    It’s possible?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    The AMP shouldn’t load on the Desktop on the normal setup.

    It should just work on the /amp urls. So we already have what you need.

    Do you have “Take Over” option enabled? (it’s located under Settings > General)

    Hello Ahmed,

    Firstly thank you a lot for this great plugin if I solve my problem I will but it for my sites!

    But:
    I had same problem but you got the issue wrong.

    He means who uses mobiles should use directly version and who uses desktop they should see current theme.

    We are not talking about /amp ending. We are talking about using this plugin for only mobile devices. I hope you got it right.

    Will like to hear you back with my best regards:)

    Hey mates I found the solution!

    Don’t change any of these, these need to be be off:

    1-)Convert AMP to WP theme (Beta)

    2-)AMP Takeover (Beta)

    And follow these way:

    AMP plugin-AMP Settings and turn on ”Mobile redirection with tablets”

    So your desktop will be stay non-AMP with current theme and your mobile will be AMP with AMP theme…

    So both look beautiful and fast!

    I will upgrade to pro version! Thanks for great AMP plugin mate!

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Here’s the details on how to use Mobile redirection: https://ampforwp.com/tutorials/article/how-to-redirect-all-mobile-visitors-to-amp/

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.