I think the wording of the select list options could be improved quite a bit. The current options are:
- Don't Subscribe
- Replies to my comments
The first, Don't Subscribe is good, but the others should also be verbs. Users scan text rather than read closely, and from a usability perspective verbs are much better for choices like this. The first choice clearly states the action they're taking: Don't Subscribe. Nice and obvious.
The others could say something like Notify me of replies to my comment and Notify me of all comments on this post. It's longer, but much more clear. They should also go in that order, ascending from no notifications, to some, to all.
I understand a change like this creates an issue with your existing localization files, so it's a bigger change than it appears. I believe the benefits are worthwhile though.