Support » Plugin: Yoast SEO » URLs with page/5/?cat=-1 Indexed in Gooogle

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support amboutwe

    (@amboutwe)

    I’ve investigated this issue in the past for other users and could not determined where Google found these URLs.

    The /?OPTION=-1 is a default WordPress feature that says show all of the content for that option (category in this specific case). At some point in time, Google discovered these links. It could be from something inside your WordPress setup or someone incorrectly linking to your site. Unfortunately, there is no easy way to determine how Google found these links.

    The best advice I can provide is to ask Google to remove links from search results.

    hey, thank you for replying. I think this is because of the archive pages pagination. on my site, I had selected to show 5 posts per page, so that created the pagination.

    well, I changed that option from WordPress to 20 posts per page. After that, all these kinds of indexed pages in google search results show a 404 error.

    Now I have removed those 404 error URLs from the search console.

    so I think this is because of the pagination.

    Also, I need advice, is it bad for SEO if these kinds of paginated URLs are indexed in google. will it hurt my rankings or create a duplicate content error.

    Jackson

    (@aframeforward)

    It seems everyone is stumped on this /?cat=-1 issue.

    I spent a crazy amount of time on support chats/calls with Yoast, Divi (my theme), Google Webmasters Forum, and then I hit a dead end here.

    I was told it wasn’t even a WordPress issue by an admin here, and they were actually offended by me. It was weird.

    I’m still holding out hope to find the right solution. I’ve had many suggestions…only to get suggestions against those suggestions, including asking google to remove the pages, as they say that could affect real content not getting indexed as well.

    Here’s what seemed to be the best advice from the thread over on Google Webmasters Forum: https://support.google.com/webmasters/thread/27682311?hl=en&msgid=27682311

    I’m still holding out hope for a better solution before I try that code snippet.

    If I find a solid solution I will report back, and please do the same as well.

    Cheers and good luck! =D

    Plugin Support Pcosta88

    (@pcosta88)

    @rohanpro12

    We are not sure if on your specific site if it will or will not be problematic for SEO. We can only say if you do not want those URLs to appear in Google to have Google remove them using this guide: https://support.google.com/websearch/answer/6349986. This is especially true if the pages are 404s.

    We are also not sure if they will or will not create a duplicate content error on your specific site either. We can only say if you remove the URLs no duplicate content issues should appear as you are telling Google to remove the URLs.

    @aframeforward

    If you are still experiencing the issue per the forum guidelines, we ask that you please create separate topics for the issues you are experiencing. That way it’s easier to track issues and provide assistance on your specific concerns on your specific site. Plus, you will get your own alerts for the issue rather than someone else’s. You may make a new topic here: https://wordpress.org/support/plugin/wordpress-seo/#new-post. Thanks!

    Jackson

    (@aframeforward)

    Thanks @pcosta88 and I’m just not sure how to get any help with this here.

    I made my original post (https://wordpress.org/support/topic/category-pages-coming-up-in-google-search-results-instead-of-the-actual-post/) before later narrowing down thru other support systems that it was for sure a WordPress issue. That post somehow offended one of the admins and in hindsight now I’m guessing because the forum here removed (as redundant) the most important part of the link, it must have made it unclear what my real issue was at a quick glance.

    Another admin stepped in later to apologize and explain. And after noticing that the forum automatically removed the link in the post I tried to make a new post that was super simple and nailed down the exact issue this time. BUT, that was then deleted by one of the admins and I was told not to post more than once. I then asked if I could take the original post down and just go with my 2nd much more precise post, but to no avail or even a response.

    I just don’t know what else to do from here.

    Thanks for your help, it is much appreciated!

    =D

    Plugin Support Pcosta88

    (@pcosta88)

    @aframeforward

    We apologize. We did not realize you were a Yoast SEO Premium user. You are entitled to a different support system then posting on the forums. We ask that you please submit a ticket to support@yoast.com that way we can investigate the issue and review account settings in order to offer a resolution for the issue you are having.

    Jackson

    (@aframeforward)

    @pcosta88 I’ve already been through the support with Yoast. And also Elegant Themes, and Google Webmasters Forum, etc.

    They all point me back here to try to figure out this WordPress issue.

    Any other ideas on how I can prevent these pages from being created, or at least keep them out of search results, without effecting the actual content I want to show up there?

    I really appreciate the help, thank you!

    Plugin Support Pcosta88

    (@pcosta88)

    @aframeforward

    WordPress rather than Yoast is creating those URLs like https://www.mysite.com/page/3/?cat=-1. There might be a way to disable it but we are unable to provide support for that option here.

    We can say to instead make a support post in the WordPress support forum (rather than this Yoast support forum) here https://wordpress.org/support/forum/miscellaneous/.

    Alternatively, there might be a plugin that can disable it as well. We suggest reviewing the WordPress plugin repository for a plugin that can best match your needs: https://wordpress.org/plugins/.

    Note, we are not sure what the outcome will be on the site if you are able to disable the creation of those URLs. So we highly suggest testing any option on a staging site. Your host provider can help create one if needed.

    In terms of getting them out of Google, we can only suggest to use Google’s removal tool here https://support.google.com/websearch/answer/6349986 and then wait for Google to remove it.

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to a lack of activity.

    You’re always welcome to re-open this topic. Please read this post before opening a new request.

    Thanks for understanding!

    Jackson

    (@aframeforward)

    Thanks @pcosta88 I’ve made a post about this in the forum you suggested. Fingers crossed that someone has a solution.

    All the best!

    Good Day!

    Please allow me to chime in. Our website experienced this same issue for a long time (i.e., Google indexing of unwanted /?cat=-1 pages).

    I did some homework and have concluded that the issue is caused by WordPress (not our Theme nor Yoast). For details, click here.

    To fix this issue, perform the following:

    (1) Install the plugin “Code Snippets.”

    (2) Add the following code/snippet to your website:

    <?php 
    if (isset($_GET['cat']) && $_GET['cat'] == -1) {
          header('HTTP/1.0 404 Not Found');
          exit;
    }

    Notes:

    (a) Kudos to Barry Hunter for the snippet.

    (b) Make sure the snippet is activated for both the back-end and the front-end of your website (the plugin explains this in more detail).

    (c) As an option, instead of installing the plugin, you can add the above snippet to your functions.php file. However, I recommend using the plugin since you’ll be able to easily delete both the plugin (and snippet) after WordPress updates/fixes their code.

    (3) Verify that all unwanted /?cat=-1 pages are now being redirected/labeled as 404 pages (simply perform a URL search of the unwanted page).

    (4) Visit website below to remove permanently all unwanted /?cat=-1 indexed pages.

    https://www.google.com/webmasters/tools/removals

    (5) Wait for Googlebot to recrawl your website (1-30 days). Voila, all unwanted pages will no longer be indexed.

    Last, but not the least, let’s hope WordPress is aware of this and will do something about it.

    Cheers!

    Salvatore

    (@scapolupogmailcom)

    Real problem for many blogs.
    Some idea could be putting noindex meta tag on that pages, same thing they do some years ago when was possibile putting /page in noindex.

    I suppose that Yoast could put a simple option for deindexing (i.e <meta noindex>) with some new update. I really hope that!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘URLs with page/5/?cat=-1 Indexed in Gooogle’ is closed to new replies.