urls with hyphens not redirecting (4 posts)

  1. dadra
    Posted 1 year ago #

    I just rebuilt a small php site in wordpress. I have set up 301 redirects using the redirection plugin, pointing all the old urls to the new urls. Like this:

    Source URL: /about-david.php
    Target URL: http://davidboyntoncabinetmaker.com/about-david

    Source URL: /contact.php
    Target URL: http://davidboyntoncabinetmaker.com/contact


    The weird thing is that the redirects work fine for the urls that are just a single word...like contact.php...but the urls with hyphens in them...like about-david.php...are giving a 404 error.

    I've never run into this issue before. Any advice?


  2. dadra
    Posted 1 year ago #

    Solved. Not sure why, but somehow there were some invisible characters at the end of some of my urls in the redirection fields. Had to retype them/clear them. All good now.

  3. janwyl
    Posted 1 year ago #

    I had this too and would never have found it without coming across this post. It was driving me nuts.

    No idea how they got in there, but there they were...

  4. dadra
    Posted 1 year ago #

    If I recall, those invisible characters may have come from having copied the urls directly from a google search results page. Some vestigial junk might have come along for the ride. I'm glad this post was helpful!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Redirection
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic