Support » Plugin: WP Hide & Security Enhancer » Urls doesn’t revert back after deactivating plugin

  • Resolved magedmoh94

    (@magedmoh94)


    Hello,

    Firstly i want to thank you so much for the great effort you put in this plugin.

    Secondly, we have been facing an issue after deactivating the plugin where the urls of the images still uses the masked url we provided in the plugin setting for the wp-content , so images are broken after deactivating the plugin & when we in-spectate in dev mode of the browser we find that the urls are still loaded with the masked url not revert back to original urls.

    Our site setup: Siteground Hosting with The New site tools.
    in plugin setting we have the wp-content changed to th-tent.
    We are sure that the cache is cleared and hosting cache is cleared, and browser cache is cleared that even happens in incognito mode.

    We even checked the .htaccess lines after deactivating the plugin all the lines there are removed

    BEGIN WP Hide & Security Enhancer
    ..
    END WP Hide & Security Enhancer

    So how can we solve this issue, we are not going to deactivate the plugin completely we just need to solve this situation we faced.

    Even in another situation: if we still have the plugin active and the current changed mask url of wp-content is “ht-tent”, if we tried to change it to any other thing like “blablalba”, it gives the same result some images are broken and urls still uses the old masked url “ht-tent” that appears in the inspectate mode.

    Stay safe for you & your family

    Best Regards

    • This topic was modified 1 month ago by magedmoh94.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Maya

    (@tdgu)

    Hi,
    Sorry for this, once the plugin is disabled, everything should revert back to default URLs. If that do not happen, somehow some of the image URLs were saved with a customized slug on the server-side and now they are outputted that way. This has been an issue years ago, on certain set-ups, such a problem occurs, however, is has been fixed at that time, so not sure if this is your case.
    You can use the following code to reverse the urls to default https://www.wp-hide.com/revert-media-files-urls-default-format/ I highly suggest creating a database back-up before starting, just in case.
    If you prefer so we take care of this for you or need additional assistance, please feel free to contact us.

    Thanks

    Thread Starter magedmoh94

    (@magedmoh94)

    Hello Maya,

    Thank you so much for the fast reply .. we will contact you with further details through the contact form on the plugin website so kindly check ur inbox.

    Stay Safe for you & your family

    Best Regards

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.