Support » Plugin: FancyBox for WordPress » URL with ?ssl=1 / Fancybox doesn’t open

  • Resolved daGuschtl

    (@daguschtl)


    Hi,

    I have installed the Jackpack plugin on my website. Unfortunately they append now a “?ssl=1” to each image-link. Due to this the fancybox doesn’t recognize the image as an image (the picture is loaded directly in browser insted of the fancybox).

    I can confirm this is caused by the “?ssl=1” in the URL.
    How can I fix this?

    Thanks

    • This topic was modified 3 years, 3 months ago by daGuschtl.
    • This topic was modified 3 years, 3 months ago by daGuschtl. Reason: typo

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter daGuschtl

    (@daguschtl)

    I found the solution myself:

    You need to edit the fancybox.php and change to follwing line (line 235):
    var thumbnails = jQuery("a:has(img)").not(".nolightbox").filter( function() { return /\.(jpe?g|png|gif|bmp)$/i.test(jQuery(this).attr('href')) });
    to
    var thumbnails = jQuery("a:has(img)").not(".nolightbox").filter( function() { return /\.(jpe?g|png|gif|bmp)\?.+$/i.test(jQuery(this).attr('href')) });

    In detail: \.(jpe?g|png|gif|bmp)$ to \.(jpe?g|png|gif|bmp)\?.+$

    Maybe the developer can fix this?
    Otherwise we have to edit this after each update.

    BRGDS

    Any word from the developer on fixing this so it does not break after updates? Granted I don’t think the plugin has been updated in a few months.

    Thanks for the fix though!

    • This reply was modified 3 years, 2 months ago by ccolotti.
    Plugin Author colorlibplugins

    (@colorlibplugins)

    @ccolotti – the Colorlib team is working on updating this plugin, as you can see here: https://github.com/ColorlibHQ/fancybox-for-wordpress/pull/28

    The issue you’ve reported above will be fixed in the next update as well.

    Thanks,
    Cristian.

    Thread Starter daGuschtl

    (@daguschtl)

    @colorlibplugins – the .jpg?ssl=1 problem is still there with v3.1.2
    BRGDS

    I’m having the same issue in 3.1.2

    Plugin Support mplusb

    (@mplusb)

    Hello @filona,

    Thank you for letting us know about this.
    We will release an update in a week or so addressing this.

    Thank you,
    Mihaela

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘URL with ?ssl=1 / Fancybox doesn’t open’ is closed to new replies.