WordPress.org

Support

Support » Plugins and Hacks » Quick Cache (Speed Without Compromise) » URL with Query Strings Cached even though Option is Disabled

URL with Query Strings Cached even though Option is Disabled

  • One of my reader notice comments did not show up when accessing my site via RSS links, unless they were logged in.

    I’m using feedproxy, so the links look like:
    http://feedproxy.google.com/~r/cnx-software/blog/~3/DJmNbJGy-zU/

    and then it’s redirected to something like: http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cnx-software%2Fblog+%28CNXSoft+-+Embedded+Software+Development%29

    I’m running the latest version of Quick Cache Lite, with the two relevant options:
    * Caching Enabled for GET (Query String) Requests? No, do NOT cache..
    * Caching Enabled for RSS, RDF, Atom Feeds? No, do NOT cache…

    But when I check the cache files (in wp-content/cache) I can see versions with query strings are also cached:

    grep grep "first-bay-trail" * | grep -v recent | grep utm_campaign
    qc-c-03c544a9d3qc-c-03c544a9d3c43ed1deb117374ce0cba1-c490de69d689a4bd17d8c2815219b621-a522e2638033c20183d18f838f53c158:<!-- Quick Cache file built for (http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed:%20cnx-software/blog%20(CNXSoft%20-%20Embedded%20Software%20Development)) in 0.97152 seconds, on: Apr 19th, 2014 @ 2:51 am UTC. -->
    qc-c-06b2d23d06dc5590b538f09ebde79470-aee4a4056a703965e91e3e85bd9bd0cf-a522e2638033c20183d18f838f53c158:<!-- Quick Cache file built for (http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedly&utm_reader=feedly&utm_medium=rss&utm_campaign=intel-announces-its-first-bay-trail-fanless-nuc-kit) in 0.91369 seconds, on: Apr 19th, 2014 @ 3:06 am UTC. -->
    qc-c-212875296baf23d30560c0fce4f1eb24-c9899e65c4659e214013be3c4b485000-a522e2638033c20183d18f838f53c158:<!-- Quick Cache file built for (http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cnx-software%2Fblog+%28CNXSoft+-+Embedded+Software+Development%29) in 0.98485 seconds, on: Apr 19th, 2014 @ 2:50 am UTC. -->c43ed1deb117374ce0cba1-c490de69d689a4bd17d8c2815219b621-a522e2638033c20183d18f838f53c158:<!-- Quick Cache file built for (http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed:%20cnx-software/blog%20(CNXSoft%20-%20Embedded%20Software%20Development)) in 0.97152 seconds, on: Apr 19th, 2014 @ 2:51 am UTC. -->
    qc-c-06b2d23d06dc5590b538f09ebde79470-aee4a4056a703965e91e3e85bd9bd0cf-a522e2638033c20183d18f838f53c158:<!-- Quick Cache file built for (http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedly&utm_reader=feedly&utm_medium=rss&utm_campaign=intel-announces-its-first-bay-trail-fanless-nuc-kit) in 0.91369 seconds, on: Apr 19th, 2014 @ 3:06 am UTC. -->
    qc-c-212875296baf23d30560c0fce4f1eb24-c9899e65c4659e214013be3c4b485000-a522e2638033c20183d18f838f53c158:<!-- Quick Cache file built for (http://www.cnx-software.com/2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+cnx-software%2Fblog+%28CNXSoft+-+Embedded+Software+Development%29) in 0.98485 seconds, on: Apr 19th, 2014 @ 2:50 am UTC. -->

    Which is most probably why people who are not logged in and come via the RSS feed do not see comments.

    https://wordpress.org/plugins/quick-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Raam Dev

    @raamdev

    Thanks so much for the bug report! That definitely should not be happening.

    Lots have things have changed in the upcoming release, including how cache files are stored (cache files no longer look cryptic but rather follow a natural orter like 2014/04/18/intel-announces-its-first-bay-trail-fanless-nuc-kit.html).

    Would you be interested in testing the latest development copy of Quick Cache to see if this bug still exists? In my tests it seems fine, but I’d love to get a second confirmation that this bug doesn’t still exist:

    https://github.com/WebSharks/Quick-Cache/archive/000000-dev.zip

    I’ve updated to the latest version, and I think the problem still occurs.

    The cache structure now looks like:

    marvell-armada-370-processor-datasheet-released-mainline-linux-kernel-supported-on-netgear-readynas-102104.html
    ./marvell-armada-370-processor-datasheet-released-mainline-linux-kernel-supported-on-netgear-readynas-102104.q/c21a892a88d0583e7f47b68ffe423063.html

    A “.q” directory is created with a cache for the RSS feed link.
    Same settings as before in Quick Cache Lite:
    * Caching Enabled for GET (Query String) Requests? No, do NOT cache..
    * Caching Enabled for RSS, RDF, Atom Feeds? No, do NOT cache…

    I’m using nginx + php-fpm, if that matters.

    Plugin Author Raam Dev

    @raamdev

    Thank you very much for the additional information. I will attempt to reproduce this issue and get back to you when I know more. I’ve opened a bug report here where I will track updates:

    https://github.com/websharks/quick-cache/issues/216

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘URL with Query Strings Cached even though Option is Disabled’ is closed to new replies.
Skip to toolbar