Support » Plugin: All-in-One Event Calendar » URL text ‘event’ is translated and breaks links

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter Sixtus78


    Interestingly the string ‘There are no upcoming events to display at this time.’, even that there is a German translation, doesn’t translate at all.

    Hi @sixtus78,

    How are you translating your calendar?

    Having all language translations full dictionaries is not an easy task.

    Our core calendar can be translated by open source user submitted language files on Glotpress. See the documentation:

    Thread Starter Sixtus78


    I installed Loco Translate for the single purpose of fixing the broken URL’s problem.
    For ‘event’, the plugins translation file has the German string ‘Veranstaltung’. I overwrite the German translation with ‘event’. Then the URL’s are generated correctly again. Does this answer your question? I translate only one string as a workaround. Without the Loco Translate fix I cannot get AIOEC running – it generates those links with ‘/Veranstaltung/’ in it.

    For the second problem, the string ‘There are no upcoming events to display at this time.’ translated correctly after deactivating W3 Total Cache. I’m troubleshooting with other plugins turned off right now.

    @sixtus78 it seems you have a very intuitive handle on things and are troubleshooting very well for you needs.

    If you have additional problems with your URLs, try changing your Settings > Permalinks, as this may reset things.

    Thread Starter Sixtus78


    I don’t understand your answer.

    Is it a bug in the plugin, that it generates translations in its links? I don’t want to install a big translation plugin to fix this one. It is just a quick workaround.


    Did you read that page?

    It’s not a plugin. These are instructions to install a user submitted translation file which doesn’t break the plugin, as your translation plugin does.

    Unfortunately, if there is a conflict with another plugin, there isn’t much that we can do to fix it, other than not using the conflicting plugin.

    Thread Starter Sixtus78


    My translation plugin doesn’t break the calendar. I have this problem without a translation plugin. So I do not understand your last reply.

    • This reply was modified 3 years, 1 month ago by Sixtus78.

    Hi @sixts78,

    Did you try my suggestion in my previous message?

    – Make sure that your Calendar page is set to the right page in the Settings > Viewing Events tab (no need to use shortcode on a page set as the default in the plugin settings)
    – Try turning on/off “Strict compatibility content filtering” in Events -> Settings –> Viewing Events.
    – Try turning on/off “Use frontend rendering” in Events -> Settings –> Advanced
    – Try resetting permalink settings to Plain and then back to your custom style
    – This error is most likely a result of a plugin or theme conflict (usually caused by a caching or security plugin).. Please try a different theme temporarily such as Twenty Seventeen, or, disable all plugins and then check if the problem recurrs — then re-enable each one until you find which one caused the problem.

    Let me know the results.


    I have the same problem unfortunately, although in Dutch. @sixtus78, could you tell me how you fixed it in the end? I’ve been trying to adapt the translation files from AIOEC, but to no avail.


    Hi @hannescratches,

    Can you tell me which method you used to translate your calendar to Dutch?

    Hi @sunny454,

    I did not actively choose the method, the plugin came with a standard set translations, which were activated (I presume) by the fact that my website settings were put to Dutch.

    Hi @hannescratches,

    Can you open a support ticket so we can look further into your settings? Please log into your Timely account and open a ticket by clicking on the Get Help link, or click here:

    Hi @sunny454,

    I did, thank you!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘URL text ‘event’ is translated and breaks links’ is closed to new replies.