Support » Plugin: WP to Twitter » How to Tweet post excerpt URL

  • Resolved


    I’ve been sending out a variety of Tweets from two different accounts, #samefacts (account for a community blog) and #markarkleiman (the individual author account). I’ve got it configured to send #title# – #name# #url#, but this formula fails when the author fills out the post excerpt. It is important to add the URL to the tweet, so it can be followed to the blog post. How can this be configured?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Joe Dolson


    What do you mean by ‘this formula fails’? Do you mean that no tweet is sent if the post excerpt is added?

    Or are you actually referring to the custom tweet field? In the custom tweet field, if you don’t include the #url# template tag, the url will not be included: the custom tweet field is fully custom, and will only include what you’ve placed in the field.

    Sorry Joe — that was a clumsy description.

    What I mean is the tweet will ONLY be the excerpt and leave out the URL entirely. So my goal would be to combine the excerpt field (as described in the page post) with the url. Trying the “#post# #url#” formula has not gotten it working.

    Plugin Author Joe Dolson


    How many characters are your settings allowing for post excerpts? It needs to be under 121 in order to also allow room for a URL.


    I’ll try that out. But keep in mind that I’m not calling for the excerpt; instead I’m using #title#. So for some reason, WP Tweets is sending out the post excerpt instead for any and all times there is one available.

    Ideally, what I’d like to design is something that posts:
    #Title# (or excerpt, if available) #url#.

    Right now it is posting either:
    #Title# #url#

    I’ll let you know if I can get it working. Thanks Joe.

    Plugin Author Joe Dolson


    Just for the record, this got figured out outside of the forums, and is working just fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘How to Tweet post excerpt URL’ is closed to new replies.