Support » Plugin: WordPress Importer » URL slugs not imported correctly (v0.5)

  • Resolved Kenn Wilson


    I’m attempting to import posts from one WP 3.2.1 site to another using WordPress Importer 0.5. Things seem to be running smoothly, except that URL slugs (post_name in the wp_posts table) are not imported, which results in some posts having different URLs on the new site. This affects posts that have edited URLs; posts that do not use the default WP-generated one. This is a pretty big problem for people doing site migrations, as a simple domain redirect to the new site will result in lots of broken URLs.

    I’ve confirmed that the post_name is exported correctly and does appear in the XML file. Something is happening upon import though, and the post_name fields in my database are all the default slugified version of the post titles. I’ve verified this problem using exported data from two different WP sites, importing to two different other installations.

    Anyone else seen this or know a fix?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I just downgraded to WordPress Importer 0.4 and see the same problem, so this may be due to a change in the exported output from current versions of WP.

    Plugin Author Jon Cave


    I just tried to reproduce this by taking an existing export file and modifying the post_name fields of one of the posts. After importing the post_name in the database had the modified value and the generated URLs used the custom value too.

    This sounds strange if you’re seeing the expected values in the XML file.

    Have you tried deactivating all other plugins before importing?

    If this doesn’t work would you be able to send me an export file to test myself? Email wp /AT/ if possible.

    Ok, I didn’t deactivate my other plugins and upon doing that I realize that another plugin was at fault. This is WordPress 101, I know. Sorry for the false alarm.

    I didn’t spend much time digging into it, but at a glance I suspect the conflicting plugin is Singular.

    Thanks for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘URL slugs not imported correctly (v0.5)’ is closed to new replies.