[resolved] url shows IP not domain after EC2 Bitnami instance stop/start (3 posts)

  1. John
    Posted 4 years ago #

    I wanted to back up my EC2 Bitnami WordPress Multi-site instance (I'm new to all of this) so I turned it off, made an image, and turned it on. My site was then broken - trying to resolve to an EC2 address.
    Now, to make a long story short, my child site displays it's url correctly, but my main site is showing the ip address. I tried changing
    define( 'DOMAIN_CURRENT_SITE', '' ); to
    define( 'DOMAIN_CURRENT_SITE', 'http://mydomain.com' );
    Likewise with wp options > siteurl and home in the database, but that breaks things.
    Anyone know what to do?

  2. You need to 'move' Multisite to the domain name.


  3. John
    Posted 4 years ago #

    Aha! Part of the 'long story' I mentioned when trying to fix things was running, via ssh, a tool that ships with the stack installer that you can use to update the domain name in the database. For some reason I updated it to the IP rather than the domain name. (But still, I thought I'd tried changing every instance of the IP to the Domain in the database by hand.)
    See: http://answers.bitnami.org/questions/1823/bitnami-wordpress-stack-in-aws-cluster-computer
    Thanks for your help Ipstenu. What would make the 'Moving WordPress' article clearer is to know whether the IP address is EVER used over the domain name in the database and where.

Topic Closed

This topic has been closed to new replies.

About this Topic