WordPress.org

Support

Support » How-To and Troubleshooting » url rewriting not working

url rewriting not working

  • invisibled
    Member

    @invisibled

    hey everbody, i’m fairly new to word press, but have been developing in php for 2 years. I’ve recently been playing with mod_rewrite but it never works. Now that i installed WP and tryed to get it working VIA the admin section it still won’t work. i have wp_list_pages listing the pages and when i click on them it just says page not found. Oh yeah, and i’m doing this all on local host. My .htaccess file is writeable, and wp inserted the code into it.

    so i think it might be a problem with my appache or php. can anybody throw ideas at me, to get it working. Even if there completely noob ideas, i wouldn’t rule anything out lol.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Jeremy Clark
    Member

    @jeremyclark13

    Assuming mod_rewrite is loaded and enabled then you need to change the deafult “AllowOveride” setting in order for Apache
    to take notice of any .htaccess directives in the default website

    Open your apache httpd.conf file.
    
    FIND SECTION BEGINNING
    <Directory "/var/www/html">
    
    Options Indexes FollowSymLinks
    
    AND CHANGE
    AllowOverride None
    TO
    AllowOverride All
    
    Order allow,deny
    Allow from all
    
    </Directory>
    
    SAVE FILE AND THEN
    
    # service httpd restart
    invisibled
    Member

    @invisibled

    THANK YOU SO MUCH

    i have been trying to get this working for like…. way to long!

    tiroirdelmare
    Member

    @tiroirdelmare

    Fantastic,

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘url rewriting not working’ is closed to new replies.