WordPress.org

Forums

[closed] URL redirects breaking functionality. (7 posts)

  1. SeanBanksBliss
    Member
    Posted 1 year ago #

    My problem is at: "automaticallynow.com" for some reason all "http://www." links are being redirected to non-www urls (just "http://") and they don't necessarily go to the right pages. For example: This page is the correct one http://automaticallynow.com/make-money-online/go/mmo-list-opt-in/ but if you add www. to it it redirects to the home page.

    This has been happening since I setup the multisite network. It's destroying my ability to use things even though they are "multisite" compatible like WP Lading Pages plugin. The problem exists even when NO PLUGINS are active. I have also tried switching between the annual default "twenty" themes with no improvement.

    Note the WordPress installation is with in the /make-money-online/ directory.

    I spoke with my hosting support. We didn't see anything in the .htaccess file to cause this, but I am not .htaccess literate.

    Contents of the WP install .htaccess file:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /make-money-online/
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    Inside my multisite administration the URL's are listed in a few places. On the main site in permalinks they all look like this: http://automaticallynow.com/make-money-online/, no WWW.

    When I edit the site via "network admin" it shows:
    "Siteurl http://automaticallynow.com/make-money-online" and this is not showing any ability to edit that.

    Also when setting up the multisite network, the setup instructions had me do this:
    "Add the following to your wp-config.php file in /home3/imuaaloh/public_html/automaticallynow/make-money-online/ above the line reading /* That’s all, stop editing! Happy blogging. */:
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'automaticallynow.com');
    define('PATH_CURRENT_SITE', '/make-money-online/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    "
    I'm told that "WordPress can be installed with or without the www.'s it looks like this one was installed without them. However, the hosting account is set up to have the site resolve to the same page when the domain is typed in with or without the www's". But if that was the cause then this page http://www.automaticallynow.com/make-money-online/go/mmo-list-opt-in/ would be redirecting to this page http://automaticallynow.com/make-money-online/go/mmo-list-opt-in/ NOT to the main sites home page http://automaticallynow.com/make-money-online/.

    The pattern persists on other links and test pages.
    # Commenting out " RewriteBase /make-money-online/ " from the .htaccess file did not seem to change anything.

    Removing the .htaccess file resulted in all pages having Bluehosts 404 message. This is predictable since wordpress multisite doesn't know what to do without those .htaccess contents. But when we took out the file the redirect did stop and the 404 errors were for the exact URL including "WWW."

    Still not sure if it is .htacess or WP network causing the redirect. Blue host chat support was unable to find anything in the .htaccess to cause it. Which would mean that it must be something about using the wordpress multisite setup.

    Additional Notes:
    A redirect detector tells me its a 302 temporary redirect when using a URL OTHER than the home page. When usinging http://www.mydomain.com/homepage/ it becomes a 301 permanant redirect. Not sure if that factors in here of not.

    I don't mind URLs like http://www.automaticallynow.com/make-money-online/go/mmo-list-opt-in/ being redirected to thir non-WWW versions, but having them redirected to mydomain.com/homepage/ (http://www.automaticallynow.com/make-money-online/) is messing things up. Can you help me determine the cause of this problem?

  2. Why is the /go/ part in your URLs?

    WordPress uses a feature called canonical URLs so that if WordPress gets a request that doesn't exist i.e. /go/post-slug then it figures it out and redirects the browser to the correct post URL.

    http://codex.wordpress.org/Function_Reference/redirect_canonical

    Also the WordPress Address (URL) and Site Address (URL) define what hostname the WordPress generated URLs will contain.

    http://automaticallynow.com/make-money-online/wp-admin/options-general.php

    If those do not contain www then the URLs will not have that in front of them. That's not something that you can change with .htaccess. If you want to keep the www (I wouldn't as it's very late 1990s...) you can change that in those two field settings.

  3. SeanBanksBliss
    Member
    Posted 1 year ago #

    The /go/ is from the WP landing pages plugin. And now that you mention it, I've only been testing it with those URLS! That was StUoooopid! I just tested it with regular single post url and it works fine! So it has to be plugin related! Some how the plugin (which I really really like!) didn't make the switch to multisite correctly.

    Unfortunately the plugin developers said the plugin is multisite compatible AND that the problem was too specific so I'd have to pay them $7 an hour to troubleshoot it! THATS NOT HAPPENING!

    What can I do to drill down into this issue and solve it!? If the plugin "is compatible" then the linking errors are from the plugin. But I've replaced all the plugin files with fresh ones. It must be in the database section relating to the plugin right?

    How do I figure out how to fix the plugin.

    I guess I'll have to repost the problem in the plugin forum?

  4. I guess I'll have to repost the problem in the plugin forum?

    You could if you want to but as I said WordPress will behave that way based on the setting that WordPress has for your site and URLs.

    Unfortunately the plugin developers said the plugin is multisite compatible AND that the problem was too specific so I'd have to pay them $7 an hour to troubleshoot it! THATS NOT HAPPENING!

    It happens. ;) If the plugin is supposed to be multisite compatible then that's a good reason to post in that plugins support sub-forum.

    But... a plugin like that should NOT be used in multisite. Those landing pages should be site specific and activating it in your multisite network dashboard wouldn't make sense to me anyways...

  5. SeanBanksBliss
    Member
    Posted 1 year ago #

    I meant to say $70 an hour, not $7. It's not about activating it network wide. It was active on the original site. I deactivated, converted to a multisite setup, I don't need it on every site, but I do need it on at least one -- the primary. At the moment it doesn't matter how or where I activate it, all the linking functions within it are malfunctioning.

  6. SeanBanksBliss
    Member
    Posted 1 year ago #

    I started posting about this in their support forum a week or more ago. they started to try to figure it out but never got anywhere then they gave up and said "give us $70 an hour and we'll look into it for you". Their support will not be supporting me apparently.

  7. Hey, Sean... You already have a post about this.

    https://wordpress.org/support/topic/urls-being-redirected-when-www-and-other-mysterious-urllink-issues?replies=4&view=all

    Please don't make multiple posts. I'm closing this, you can carry on in your other thread.

Topic Closed

This topic has been closed to new replies.

About this Topic