Support » Fixing WordPress » URL redirect to WP site doesn’t work

  • Resolved Spright

    (@spright)


    Hello all!

    I set up a URL redirect from http://www.mydomain.com to my WordPress website. But it doesn’t work — on any browser, but only Firefox shows a useful message:

    Firefox Can’t Open This Page

    To protect your security, http://www.wpdomain.net will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

    What can be done? Is this perhaps related to content security policy (CSP), and can be rectified by adding something to the site’s <meta> tag? If so, I’ve no idea how to do this.

    Thanks!

    • This topic was modified 2 weeks, 2 days ago by Spright.
Viewing 3 replies - 1 through 3 (of 3 total)
  • I set up a URL redirect from http://www.mydomain.com to my WordPress website. But it doesn’t work — on any browser, but only Firefox shows a useful message:

    How did you set up this redirect? What exact steps did you take?

    Thread Starter Spright

    (@spright)

    I did it at my domain registrar, in the DNS editor.

    I defined two masked URL redirect records: one for @ and one for www. The value in both: the target website, written fully as https://www.wpdomain.net/WPWebsite.

    I have an identical redirect from another domain to another WP website, hosted elsewhere, and it works just fine.

    I believe the problem isn’t with the redirect. As we can see in Firefox’s error message, the redirect is able to point to the target domain. I suspect the problem is with WordPress’s security definitions at the target website.

    Thread Starter Spright

    (@spright)

    I had to turn to my hosting provider’s technical support.

    They added the following rules to .htaccess for the target website:
    ####
    Header always unset X-Frame-Options
    Header always unset Strict-Transport-Security
    Header always unset X-Content-Type-Options
    ####

    That’s it, solved.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.