Support » Plugin: JSON API » URL redirect me to Homepage

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author dphiffer


    Hi razarahil, it looks like ?json=1 doesn’t work either. Is the plugin still enabled? Maybe there’s another plugin doing the redirect?

    Yes the plugin is still enable and no other plugin redirecting it.

    Redirect happened because of my permalink. I created a test blog on a server with permalink structure /%postname%.html The plugin didn’t work

    Then I changed the permalink structure to /%postname%/ and this time plugin works.

    Can you please add fix so that we can use it with a later one. I can’t change permalink structure right now I’ll affect my blog badly.

    Plugin Author dphiffer


    I don’t think it’s the permalink structure (see: Maybe it’s a server setting? I would check your Apache configuration for mod_rewrite rules.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    I’m also using W3TC.

    Plugin Author dphiffer


    Those rewrite rules look pretty standard. If you disable W3TC does that make any difference?

    Any tip on how i can solve WordPress SEO plugin & JSON API plugin conflict? JSON API feed URL redirects to homepage. I am trying to pull feeds from my blog via JSON API to an Android app am building but the JSON Feed URL keeps redirecting to the homepage, so i figured if i disable all the plugins i can narrow down the source of the trouble, so i did and discovered that any time i active the WordPress SEO plugin the JSON feed url redirects to my homepage.

    Anyone got any idea how i can fix this? I really need the WordPress SEO plugin and i also need to get the JSON feed url working.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘URL redirect me to Homepage’ is closed to new replies.