Support » Plugin: FireStorm Professional Real Estate Plugin » URL problems in Real Estate backend

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author FireStorm Plugins


    Hello, the plugin uses the URL you stated when setting up WordPress. There are two fields in your WordPress Dashboard – Settings – General page. What do you have entered in WordPress Address (URL) and Site Address (URL) fields?


    Both lines have in it so those are correct. Strange thing is that when i search for the non www version in the database i don’t find it.

    I think i have found something… the plugin mentions i don’t have rights to enter some of the screens. That’s strange because i am the main admin as a user.

    the problem is in the script


    there is the variable $CurrentURL around line 22 used for generating links.

    $CurrentURL = ‘http://’.$_SERVER[“SERVER_NAME”].$_SERVER[“REQUEST_URI”];

    so the sessions don’t work if you login on your domain with ‘www.domain.tld’ and click on the ‘edit’ link that goes to ‘domain.tld’. So you get the wp login-screen. Behaviour depends on server settings.

    I just quickly changed this to
    $CurrentURL = ‘http://www.’.$_SERVER[“SERVER_NAME”].$_SERVER[“REQUEST_URI”];

    Plugin Author FireStorm Plugins


    I will look into this issue with that variable and provide a fix.

    Plugin Author FireStorm Plugins


    Hello, please download version 2.06.09 as this should resolve this issue.

    Can I know firestorm plugin working in localhost, I using wamp server, I try add listing then view the page, just get in 404 page, or have to set linking…. I am beginner, pls help. How to list out the page, thx.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘URL problems in Real Estate backend’ is closed to new replies.