Support » Fixing WordPress » URL problem

  • Resolved Alexander


    Hello. Can I have a bit of help. My site is in Cyrillic. I publish in different languages, incl. Bulgarian, Serbian, Russian, Ukrainian, Chinese and others. The problem is that when I post a post with the following title (for example) “Патријарх Порфирије разговарао са председником Бискупске конференције Словеније”, it gets the following link

    Must getпатријарх-порфирије-разговарао-са-пр-3/


    Can you tell me how to fix the problem? When I post in Latin, incl. English, I don’t have that problem.

    Best wishes,
    Alexander Angelov.

    • This topic was modified 4 months, 1 week ago by Alexander.
    • This topic was modified 4 months ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • threadi


    Which browser do you use? WordPress already saves the URLs in the correct format. However, since they are special characters (like German umlauts or Manadarin symbols), they have to be converted by the browser to process them. When I call your page, the URLs are displayed correctly in my Firefox – i.e. with Cyrillic characters. There are browsers that do not support this correct display even today. But most of the current ones do.

    Thread Starter Alexander


    Thank you for the reply.

    I’m using Chrome. But when I copy the link from the browser to Notepad, it gets the weird characters.

    Also, the problem is that I am using a membership plugin. It includes an option to redirect to last page after login. However, when the link is in Cyrillic, it cannot retrieve it correctly because it includes symbols like “%D1%80%D0%B0%D0%B7%D0%B3%D0%BE%D0%B2%D0%B0%D1 %80%D0%B0%D0%BE-%D1%81%D0%B0-%D0%BF%D1%80-3”



    Yes, this is because Notepad cannot display the special characters in any other way. Browsers convert them to the characters you expect in the URL line.

    You should report the problem with the membership plugin to its developer. Apparently it also has problems converting the special characters accordingly.

    Thread Starter Alexander


    I understand. Thank you very much. Blessings!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.