url problem (8 posts)

  1. mujtba
    Posted 3 years ago #

    we website url is "abc.net",
    i have hosted n godaddy with wp install in a folder "maadandmcc.com/ABC/"
    now when i open "abc.net" it opens fine but when i go further on anypost the url changes to "maadandmcc/aba/?p=10",

    i have tried to change custom permalinks but it doesnt allow me to completly change the permalink and make "maadandmcc.com/abc/" permanent and allow me to edit other half of permalink.

    Kindly help me in this aspect please.

  2. Krishna
    Posted 3 years ago #

  3. mujtba
    Posted 3 years ago #

    i tried this, thts why i am saying i can only edit half of permalink.."maadandmcc.com/abc/" remains same.

  4. Julien
    Posted 3 years ago #

    You have errors with your database credentials. WordPress can't connect to it. Check your wp-config.php file.

    Once you can connect, check in the "settings" tab in the WordPress admin for the options:

    • WordPress url = where core folders are
    • Site url = where you want your website to display

    So if you want to have your website at http://www.maadandmcc.com/abc/, you have to install your website under the "public-html">"abc" directory on your web server and make sure the two options above are set to: http://www.maadandmcc.com/abc/

    So when activate permalinks you get URLs like so:

    http://www.maadandmcc.com/abc/some-post-you-published/ in place of http://www.maadandmcc.com/abc/?p=10

    Hope it helps !

  5. mujtba
    Posted 3 years ago #

    @ julien
    database is fine,
    and u didnt get my question i want to change my url to "http://www.abc.net/my-post/" not "http://www.maadandmcc.com/abc/some-post-you-published/"
    but custom permalinks isnot allowing me to completely change my url its making "maadandmcc.com/abc/" fixed because my wordpress is insttalled in maadandmcc.com/ABC folder.

  6. Julien
    Posted 3 years ago #

    Well not sure to understand your question but "abc.net" and "maadandmcc.com" are 2 different domains and permalinks are not made for this.

    If you want the url to be "http://www.abc.net/my-post/" you have no other choice than install WordPress on the root of the server for this domain.

    Permalinks are equal to "pretty links". They allow you to change a query string url (?p=10) to something easily recognizable and better for seo like (/my-post). But you are sticked to the domain where wordpress is installed.

    Hope it clarifies permalinks...

  7. mujtba
    Posted 3 years ago #

    than Julien it was a confusion u help me.. thanx

  8. Julien
    Posted 3 years ago #

    My pleasure ;)

    Don't forget to mark your post as "resolved" ;)

Topic Closed

This topic has been closed to new replies.

About this Topic