Support » Plugin: nLingual » url prefix repeats

  • Resolved norm4u

    (@norm4u)


    Hi there,

    I have updated the site and the plugin and immediately after that, I have problems with the translation plugin. Currently English is off, but when it is on, the URL prefix repeats several times and eventually, the page doesn’t load at all. Back to the Netherlands is also not possible anymore. If I select Englisch I get https://www.verhaargebeko.nl/en/en/en/

    I really have no idea what is wrong.

    https://screencast.com/t/EIgJYC2nVN

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Doug Wollison

    (@dougwollison)

    Hello,

    I’ll see about debugging this later this evening; it should be a simple overlooked glitch caused by the recent subdirectory handling patch.

    In the mean time, perhaps try replacing the plugin with an older version? You can download them here: https://github.com/dougwollison/nlingual/releases (I suggest trying 2.8.1)

    Please note: do not uninstall/delete the plugin as this will delete it’s settings and translations data with it. If you have FTP access you should be able to replace it outright.

    Otherwise I should have a fix in place in a couple days tops; I need to see if I can recreate the issue first. Will keep you posted.

    Plugin Author Doug Wollison

    (@dougwollison)

    I’ve had a chance to test stuff and right now I can’t seem to recreate the issue on a sample dev site. Can you send me a screenshot or summary of what your translation settings are and how the languages are configured?

    Hi Doug,

    I have not yet tried to install an older version.
    First, I hope you know a fix for the current install.

    Here you’ll find the settings:
    https://drive.google.com/drive/folders/1Fb1f4Kz-G5Z47rRrwJApl0a3fDk_RF6m?usp=sharing

    Plugin Author Doug Wollison

    (@dougwollison)

    Sorry about the delay; been slammed at work.

    I’ve recreated your settings on another test site but still can’t recreate the issue. Are you using any plugins that might affect URLs?

    No, I’m not using a plugin that affects URLs. Is there a way that I can share access to the website?

    Plugin Author Doug Wollison

    (@dougwollison)

    Honestly, in order to debug this thoroughly, I’d need to mess around with the plugin code to test where it’s getting the double-localized URL from.

    Are you comfortable sending over a ZIP of your themes and plugins so I can sort of recreate the site? I don’t *think* I’d need any database related stuff as I can just use dummy pages and manually recreate the settings.

    You can send it privately to me at doug@wollison.net

    Plugin Author Doug Wollison

    (@dougwollison)

    Okay, I’ve setup a dev site using the themes/plugins you sent and was able to recreate the issue. I’ve thus far narrowed the cause down to the Piklist plugin. I’m attempting to find the exact cause and should have a patch figured out tonight.

    Plugin Author Doug Wollison

    (@dougwollison)

    Alrighty, that ended up being really simple. Long story short Piklist was doing something I didn’t account for (nothing wrong just… odd) and that’s what caused the redirect loop and prefix stacking. I’ve made a simple fix by having nLingual always “delocalize” the URL before localizing it, rather than only some of the time.

    You should see an update for 2.8.4 shortly.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘url prefix repeats’ is closed to new replies.