Support » Fixing WordPress » URL parameters twice in wp-admin

  • Resolved dvillarraga

    (@dvillarraga)


    Hi, It is a really weird issue, the website works fine but into wp-admin when I go to some option like post-categories, the original link is something like wp-admin/edit-tags.php?taxonomy=category but when the page is opened, it automatically repeat the GET parameter resulting in something like wp-admin/edit-tags.php?taxonomy=category%3Ftaxonomy%3Dcategory of course if I reload the page I get a 500 error. I’ve been searching if is there any problem in apache wordpress conf but the error persists even disabling everything (theme, plugins, apache rewrite rules).

    Even though If type the url with two parameters e.g. ?taxonomy=category&param2=bla the url is not modified, it looks as if the server requires 2 parameters and if it found just one, it tries to repeat it. :O

    Ubuntu 18.04.1 LTS
    PHP Version: 7.2
    Apache Version: Apache/2.4.29 (Ubuntu)
    Wordpress Version: 4.9.8

    Here my .htaccess

    
    <IfModule mod_rewrite.c>
       RewriteEngine on
       RewriteBase /site/
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_URI} !^/wp-admin/
       RewriteRule ^(.*)$ /site/index.php/$1 [NC,L]
    </IfModule>
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator bcworkz

    (@bcworkz)

    That .htaccess is not the default WP rule set. It doesn’t entirely make sense to me, but in any case it only applies to permalink requests anyway. Requests to specific files like edit-tags.php are not handled by this rule set. As you’ve already done the usual debugging steps like disabling plugins, it does seem like there is an errant .htaccess rule set somewhere, but it’s not that one.

    Are there other rule sets in this file? What about in the site’s public root? The /wp-admin/ folder?

    Hi @bcworkz,

    There are no other rule in any other folder, fortunately I’ve found the reason, It looks that the problem responds to a incompatibility between wordpress/woocommerce and ModSecurity, I have disabled ModSecurity and everything is working fine. Of course I will see how to fix it so as to establish a secure web server.

    #Solved

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘URL parameters twice in wp-admin’ is closed to new replies.