Support » Fixing WordPress » URL not included when sharing post on Twitter

  • shoutfactoryadmin

    (@shoutfactoryadmin)


    Our WordPress blog lives within a larger website, which itself is not a blog and not part of WordPress.

    For the blog section, we’re having problems with the Twitter share button at the bottom of each post. When you click it to share via Twitter on desktop, the auto-populated text includes the name of the blog post but does not include the post’s URL. When you click to share via Twitter on a mobile device, the auto-populated text includes the name of the blog post and the URL string that appears AFTER the domain, but it does not include the domain itself and is therefore not clickable.

    Is there a way to fix this so that when a user clicks to share via Twitter, the URL of the post being shared is automatically included in the shared text? I’m not very experienced with WordPress, so I’d appreciate any help that can be provided, thanks!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    It looks like you’re either using Jetpack for those sharing buttons (though I don’t see any other Jetpack features there), the old Sharedaddy plugin that got acquired by and merged into Jetpack, or some other fork.

    Would you please clarify which plugin you’re using for the sharing buttons?

    shoutfactoryadmin

    (@shoutfactoryadmin)

    I believe those are jetpack

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Ok, they definitely aren’t working right, and it seems like Jetpack is not connected on the site.

    One of the more noticeable problems is that Tweet link should actually be a button or icon, not plain linked text.

    So, first make sure that you’re running the latest version of Jetpack, which is 5.6: https://wordpress.org/plugins/jetpack/

    Then, go to the Jetpack section of your site’s Dashboard and connect it with a WordPress.com account when prompted.

    If that makes no difference, if you run into an error while connecting, or if it’s already connected, I recommend contacting Jetpack’s support at https://jetpack.com/contact-support/

    Thanks, James. I hadn’t checked out any of this before because everything had been set up before I was brought in to help with the blog.

    It does appear that we have the latest version of Jetpack. But when I try to connect it to the site, it gives messages like:

    “Your site is on Development Mode”
    “The JETPACK_DEV_DEBUG constant is defined”
    “Your site URL lacks a dot (e.g. http://localhost)”
    “Your site is in Development Mode, so it can not be connected to WordPress.com.”

    I suspect that we can’t connect Jetpack to our site unless we upgrade to pay for Jetpack. Of course, all we want is for the Facebook/Twitter share buttons to work properly. Would you be able to recommend an option to enable this that doesn’t involve using Jetpack at all?

    Thanks!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Despite having paid plans which add more features, Jetpack will always and forever have a free plan: https://jetpack.com/features/comparison/ (and the sharing buttons are a part of that free plan)

    A connection to WordPress.com is required to use most of Jetpack, and being in Development Mode prevents that, so make sure the JETPACK_DEV_DEBUG constant is not defined in the wp-config.php file: https://jetpack.com/support/development-mode/

    If that doesn’t work, or you can’t find out why the site is in Development Mode, I recommend contacting Jetpack’s support at https://jetpack.com/contact-support/

    Thanks, James. We’re going to contact our website developers to see what’s up with Jetpack being in development mode (and how we can get it turned off without breaking anything)

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.